How to set a static IP for your Umbrel server

I see a lot of users having issues connecting to umbrel.local and most of them are Windows users.

I will try to put here some simple steps so everybody can try them.

Not having access to your Umbrel doesn’t really means your Umbrel is broken. Means that the PC from where you access it can’t see it in your LAN or in the parameters you configure your LAN.

So could be 4 reasons that maybe your Umbrel is not accessible:

  1. IP assigned. The IP for the Umbrel is not set fix, or was changed by your DHCP router, or is not in the same range of your regular LAN.
  2. Your computer from where you are accessing, doesn’t know the new IP or couldn’t find the IP related to umbrel.local. Some Windows versions update that information and sometimes simply block it.
  3. Hardware issues. If your HDD/SSD with data has connection failures, the Umbrel OS will enter into a loop`and cannot be accessible.
  4. Software issues. Very rare when UmbrelOS is stuck. So in 99% of cases a restart and a good amount of time waiting to come back (re-sync the blocks) will fix it. So be patient and after restart just wait before doing any further investigation.

How could we fix ourselves these issues?

1. How to set a fix IP for my Umbrel?

Option A - setup in your router a fix IP for your Umbrel

  • enter in your router configuration
  • find DNS or DHCP server (depending on each brand)
  • set a fix IP, from your LAN range and one that is not used by other device. You can run from any Windows machine in command prompt arp -a and will see a list of all computers connected in your LAN, with their assigned IPs and MAC address. One of those could be also your Umbrel if is ON. Also you can see the MAC address on the box of your Pi.
  • so assign a fix IP using your RPi MAC address in your router
  • done, from now on, each time your RPi will be connected to that router, it will be assigned the IP you configure it.

Option B - setup a fix IP in your RPi settings

  • use Windows Powershell or Putty to enter SSH into your Rpi
  • type ssh umbrel@umbrel.local or ssh umbrel@yourRpi-IP` if you know that dynamically assigned IP (see previous point listing IPs in your LAN)
  • will ask you for a password, BUT YOU WILL NOT SEE IT. Just type your user password for Umbrel and press ENTER.
  • once you are in, configure the static IP address for the Pi, the gateway path and a DNS server. The configuration for the DHCP client (Pi) is located in the /etc/dhcpcd.conf file:

sudo nano /etc/dhcpcd.conf

The following snippet is an example of a sample configuration.
Change the value of static routers and static domain_name_servers to the IP of your router (default gateway, see Option A).
Be aware of giving the Raspberry Pi an address which is OUTSIDE the range of addresses which are assigned by the DHCP server. You can get this range by looking under the router configurations page and checking for the range of the DHCP addresses. This means, that if the DHCP range goes from to you’re good to go with the IP for your Raspberry Pi.

Add the following to the /etc/dhcpcd.conf file:

#Configuration static IP address (CHANGE THE VALUES TO FIT FOR YOUR NETWORK)
interface eth0
static ip_address=
static routers=
static domain_name_servers=

Restart networking system sudo /etc/init.d/networking restart

NOTE (Thanks @LoboGuara): If you update umbrel by reflashing a new version in SDcard, dchpcd.conf file is reseted. So make a copy of that file before you reflash your mSD card or edit again with your modifications before you start your Umbrel.

2. Add Umbrel’s IP into your hosts file

Now, once you know that your Pi will have a fix IP, you can go and add it also to your local computer, for easy accessing.

  • Go to the hosts file located into: C\Windows\system32\drivers\etc\ If you can’t see it, go to view folder options and select “show hidden files and folders”.
  • copy it onto your desktop and start editing with notepad
  • add the following line:

192.168.x.x umbrel.local

(replace 192.168.x.x with your local IP assigned for your Umbrel)

  • save the file and copy it back over the original. It will ask you to confirm, because it’s a system file. Confirm and done.
  • restart your PC. From now on your PC will always go to the assigned IP when you type in your browser umbrel.local

For Mac users, follow these steps to edit your hosts file.
For Linux users, these instructions are not valid.

3. Hardware issues.

  • Usually, most of the times, the external hard drive get disconnected (for various reasons)
  • sometimes, the power source it fails, even if are milivolts that you do not detect them, those little intrerruptions could damage some hardware or do not run properly.
  • power cuts are very serious damaging drives or files on the drives. I recommend to run your Umbrel with a backup battery that can keep ON your Umbrel several minutes until you can shut it down!

In order to troubleshoot what is happening inside your Umbrel machine, share your debug log with the community here or with the official Umbrel team. That log contains valuable information that can “tell” if there’s a component that fails. Also you can read it and see if something is wrong and maybe a quick view will give you a clue and fix it yourself. If you are not so comforbale with logs, just send to the Umbrel community the link of the log and we can take a look.

Enter SSH into your Umbrel.
Open a terminal/command prompt/powershell/putty on your computer and enter

ssh umbrel@umbrel.local

the password is your personal user password for Umbrel dashboard. When you type it, you won’t see what you type, so just type and press ENTER. If you do not change it, it is the Umbrel default password - moneyprintergobrrr

and then type

~/umbrel/scripts/debug --upload

At the end of the debug log it will be a link and instructions where to post it (on Telegram group or on Umbrel Community).

4. Software issues
Most of the times these issues come from:

  • users running Bitcoin node and not waiting until the node is fully synced and restarted or power off or do whatever any other tasks.
  • power cuts or previous installations that didn’t end well
  • mSD card get damaged. These cards are very sensitive. Always keep a copy at hand
  • updates that hangs due to disk sectors that are not in a well state
  • many other reasons that system can get unstable (it’s a simple Pi not a full server machine so expect these issues)

What to do?

  • run the debug log indicated at the point 3.
  • you can reflash the mSD card. On this card is ONLY the OS, not the data. So no user data will be lost
  • re-apply latest update. Yes sometimes, files can get corrupted and a reinstall could just write the correct version.

DONE! From now on you can access your Umbrel in your browser with umbrel.local !

Optional I would recommend to open your Umbrel dashboard using the onion address provided (after you enter with umbrel.local) and bookmark that address.


  • each Umbrel app will have a different onion address
  • NEVER share these onion addresses in the wild internet with strangers!
  • If you create a LNbits app wallet, be aware to save that wallet address in your bookmarks. It is the only way to get back to it.

I really hope that this guide will help you.



I’m trying to fixe the issue I’ve got with my node connection. I think it come from the dynamic IP adress.

I’m just block at the end of the Step 2. when you write

“For Linux users, these instructions are not valid, they already know what to do, if they already run a Linux :slight_smile:”"

The problem is that I’m a linux user but a fairly novice and I don’t know what to do…


But from this image, I would say that is not about the static IP.
Could be something else.
Try restart it and have a bit more patience until it started.

Ok I’ll do so! thank you!

I’ve got the trouble since one week approximatly, I’ve restart it several time. I was having the following error message :

“L’adresse DNS de umbrel.local est introuvable. Identification du problème…

So I’ve plug/unplug the node and the rooter at the same time and only after that I’v had the error message that I’ve already shown.

I’ll let it run all week long and we will see.

Thank you

One week since my last message and I’m still at the same point. I had try to flash the SD card again with the new Umbrel version 0.4.13 but I’ve still the same error message (see previous picture). I have restart it several time but nothing to do.

If you have an another advise I’ll be grateful

@DarthCoin There´s a issue with option 1.b (fix a IP in Umbrel).
If you update umbrel by reflashing a new version in SDcard, dchpcd.conf file is reseted.
So this seems not reliable, but need asking developers to keep dhcpcd.conf if already present.

1 Like

Thanks, will update the guide with a note you indicated.

Take the router that your pi is currently on and hit it with a sledge hammer. Then go to your windows computer and try and find your umbrel.local. Can’t find it ?. How do I reasign it to a new network? Simple reconnect it to another router? and then go to my windows computer and type Umbrel.local? This was essentially my original question. To stupid, to ignorant question to answer? Sorry.

Thank you for the detailed solution. It worked for me.

1 Like

This really helped me. The day after I started the initial block download my Mac failed to recognise http://umbrel.local

Despair set in because im not technically minded.

I followed your guide, set a static IP for my Rasperry Pi, then edited the host file in my Mac. I can now access umbrel.local.

I coudn’t have done this without your guide. Thank you!!

If we are trying to force it to a single IP, why is the CIDR /24 instead of /32?

So when I go to the IP address says it can’t be reached, do the diagnostics and it says its not responding, so I did the angry ip scanner but my node doesn’t show up. Then I go into the powershell and type in the ssh umbrel@umbrel.local but it comes up could not resolve hostname umbrel.local: no such host is known.


One question: can I put the umbrel ip as a static ip? ex: my Umbrel IP is 192.168.x.x, can I use it for static IP or should I use 192.168.x.y?


I can not access my node by umbrel.local or by ssh in the command terminal. When I try to access it via browser, I get DNS PROBE POSSIBLE. When I try to access it via terminal I get no response. I have ran IP Scanner and the IP Address does not show up. Also you mention assigning a Static IP address. How is this possible if I cannot locate the MAC address of my raspberry pi? Also, if I reflash the SD Card, can I simply remove the SD Card while my node is running. I have no way of shutting the node down without pulling the plug to it.

I’m running Win10. Got new modem from my ISP I have the ip address and mac address but computer can’t find ip address at umbrel.local
Umbrel is ‘talking’ to someone, lights flashing and modem status shows outgoing traffic from umbrel

Update, Went to modem and obtained the address and then typed it into browser address bar and after a minute or two the Umbrel login screen appeared. Logged in and all nodes now running smoothly.

Hi. Since 1.0 upgrade, change /etc/dhcpcd.conf file doesn’t work for me. This is the file:
interface eth0
static ip_address=
static routers=
static domain_name_servers=

Any idea ? Thanks.

So - i believe its totally different with the switch to debian - but none of the approaches I am familiar with for Debian for setting static IP seem to make sense for this config either (eg /etc/network/interfaces or netplan)

This pretty much breaks using the pihole app

ok - i see - its using network manager - look up nmcli

Hi. I found this:

nmcli connection show

sudo nmcli con mod “id connection” ipv4.addresses 192.168.0.xx/24 ipv4.gateway 192.168.0.yy ipv4.dns “,192.168.0.nn” ipv4.method manual

“A conexão expirou “ o servidor demorou muito tempo para responder “
Please help.
I use wsl (Linux)
Everything was working fine. Suddenly she stopped.