Node Shuts Off after 1-4 hours


My Node disconnects and stops running after a couple of hours. I have to turn off/on to get it syncing and running again and then it will shut off shortly after.

Any ideas?

1 Like

I used the Umbrel List and Links on the Umbrel Site. All Amazon.

I have been having this happen too recently. I bought all my stuff from the Amazon list of the main Umbrel site. If I unplug the power, wait a few minutes and plug it back in everything come back online in a few minutes, syncs all the blocks it missed and works just fine. Just odd that it randomly disconnects.

@diamond-hands-mcgee & @attackbtc

What you both are experiencing is SD card corruption. Every time the RasberriPi is shut down improperly you need to re-flash Umbrel software. There are also instances where the card will randomly corrupt and will need to be re-flashed though this occurs a month or two of use. If you do not re-flash then the node will go down 1 to 2 times daily. This issue will occur even with the top rated equipment. Knowing this you can now keep your node up and active for months at a time without issue.

Powering down using the GUI or SSH will not corrupt the card. Disconnecting power while its running will cause corruption every time. You will not lose any data or have to re-sync the blockchain by performing a re-flash as all the data is stored on the SSD.


Thank you for the response but I believe i may have found the issue, I was getting an error page saying there was a DNS issue. I was trying to access the node via umbrel.local, however I ran ipconfig in command prompt and them ran arp -a to get a list of all the devices on my network. I found my node address and used the IP to log in instead of umbrel.local. I believe its a DNS issue not SD corruption.

Thank You! this was key info for this N00b. :v: :+1:

1 Like

Just to clarify, I believe @Full_node is correct with the SD Card corruption. Just wanted to make sure people know to use their IP address to access their node in case they ever do have trouble with the default umbrel link



I think I need to reflash the card but I can’t shut down the Node. It doesn’t respond to anything…I tried terminal commands. Should I pull the cable out, get the SD cardf out and reflash it ?

Typically you don’t want to unplug without shutting down via software. If its not responding then pulling the power cord is acceptable, and in this case your planning to flash the firmware anyways so no harm done.

1 Like

Agreed, so glad they added that option lol. My issue was resolved after one of the last few firmware updates, haven’t gone offline in while! But anyone reading this now make sure you properly shut down your node if necessary and re-flash the OS to the SD if you have any trouble after sudden disconnects!

1 Like

What option do you mean? Worried a bit…I dosconnected, re-flashed the SD card and it was running for 9 hours and now another disconnection. Totally don’t know what the reason might be. Before I had it running for 17 days straight with no issues. Can’t connect the dotes. Any tips of what the reason might be? I’m running on recommended hardware/original power supply. I run a test after previous re-flash and it found no issues on my node.
With this difference that this time my router lost the node and can’t see it.

What version are you on?

Umbrel? Latest one downloaded from the website. Raspberry Pi 8 Gb.

Yes Umbrel. The latest version fixed the SD card corruption issue. That should be the one you downloaded from getumbrel. If you can’t find your node on the network try running AngryIP to locate it. I’ve had my router issue a new IP and needed to find the actual IP address as umbrel.local failed to work right away.

When it crashes I can’t access it from neither umbrel.local nor the IP and I see it is connected to that IP.
Not sure what is going on…It went on for 5/6 hours and it is down again. Will try reformatting SD cardf before re-flashing and I will buy a battery next week. People say that Nodes are sensitive to even minimal power supply changes.


stays in the green most of time…under 40 C. Close to 37 C.
I haven’t changed anything from that period when it worked 17 days straight and now I had 5 disconnections in every case I can’t access it no matter how I try. Wondering how many people really run batteries to support Raspberry Pi Umbrel Node
I will reformat and keep eye on the temperature this time after re-flashing.

Are you using the correct, Raspberry Pi power cable?

I’ve used RPi before umbrel with a cheap power supply and got a warning saying “low power mode”. Maybe that warning is just not visible in the umbrelOS? This is the power supply that umbrel recommends.

I got exactly that one. What is recommended temp for Raspberry Pi ? The only thing…it could have temp spikes that I’m not aware of.
it is in enclosure with one fan.
what is your opinion on additional battery to deliver stable the power?

I have’t tried that TBH, but if the issue is power-related then it makes sense. Could grab something like this if you want. I have something like that, but bigger, for my main computer.