Umbrel Node made entire network to crash

Umbrel version 0.4.16
Rasberry Pi 4 8GB
Connected over ethernet cable
Drive: SSD

My Umbrel node has been running smoothly for about 8 months or so.
It’s connected to a switch, which in turn is connected to a router/switch.

Today every single device on my network got disconnected. Not physically, though.

After toubleshooting for a while, I ended up doing the “disconnect everything (physically) and plugging everything back in, one-by-one”-routine. Everything plugged in fine and reconnected to the network just fine. Until the Umbrel was plugged in. Then everything disconnected again.

I tried to plug the Pi straight into my laptop, however it did not provide any IP.
I then did the “what not to do”, and unplugged and re-plugged the power to the Pi, and plugged it back into the network.

It connected, without disturbing the other units on the network, however it did not show the login screen.
Screenshot 2022-04-03 at 16.54.02|690x446

In the time it took me to create a user for this forum, the page reloaded and I was able to log in. I can, however, not read the logs. I get this error when pressing “Start” on “Troubleshoot”: “Error: Failed to fetch debug data.” (Which I guess could be explained by my hard power off?).

Everything is back up and running fine now, but it’s a iffy feeling having your entire network shut down because of someting isolated to the Umbrel node.
I did install Tor Snowflake Proxy on the node right after it was avalibe on the app store. But other than that I’ve made no changes to the setup of the node, other than the regular updatates.

Any idea what might have caused this?
I’ve checked the router and I am sure it’s not a DHCP conflict.


1 Like

If you installed Pi-hole too that is really affecting your network. So revise the settings.
Also consider to set a static IP for your node

Hi @DarthCoin !
There’s nothing but Umbrel running on the Pi.
I set the IP static from day one :smile:

Seems hardware issues. Verify if you still have SSD space so can do a restart, then show logs here.

I had this same behavior a couple of months ago. It began maybe a week after the Umbrel was set up. Tor Snowflake wasn’t on mine at the time so I’d suggest you rule that out.

I noticed this was only affecting all of the wired devices on my network but my router would keep working fine with wireless devices. Immediately upon disconnecting my Umbrel from my unmanaged switch, everything else on my network would re-connect. Plug the Umbrel back in, everything would lose connection again. It was almost as if the Umbrel was DOS attacking my LAN, or that the ethernet interface was creating some kind of storm or loop on the network.

When my Umbrel was in this state, I could not remotely login to it and it would also display nothing if a monitor was plugged in. I had to hard-boot it every time to recover…but then after a few days, it would enter this state again and bring down my wired network every time.

I observed this behavior probably 8 or 10 different times. It got so annoying when it would happen while I was away from home, preventing me from using my VPN and remotely connecting to any wired devices. Interestingly enough I found that I could plug the Umbrel into a smart switch, then use that switch to hard-boot it and get things working again while away.

In an effort to at least contain the issue, I upgraded my out-dated main home ethernet 8 port switch to a new managed one. Nothing fancy just a Netgear GS308e. My thought was that this might do a better job of mitigating/containing any strange behavior with the Umbrel’s interface so that the rest of my devices would be undisturbed. I also tried a few different combinations of unmanaged switches while troubleshooting this and eventually landed on Umbrel -> GS305 -> GS308e.

I never had the problem again after making these changes…though I’m still unsure of exactly what was happening there. During these several months I’m describing I would also immediately apply every Umbrel OS upgrade when one was available.

Interestingly enough the Umbrel is also perfectly stable now where previously it would often only stay up for a few days, or maybe 10 at most, before entering the state described above.

Just thought I’d share all of this in case it helps someone figure out what might be happening.

I absolutely love the Umbrel and I’m so glad it’s stable now!!


P.S. I just realized there’s another very key piece of information I have that might be helpful here. Prior to discovering and using Umbrel, I followed the howchoo guide online to build a bitcoin full node on Raspberry Pi 4. I also had this problem with that setup which I suppose points strongly toward a possible hardware problem with the Pi, or some incompatibility between it and my network… I only ran that full node for about a week or two before I switched to Umbrel.


Thanks for your detailed reply!
It’s pretty much the exact same issue that I was having.
What you mention about wifi connected devices was the same for me: they stayed on the network, however they did not have internet access.

I’ve not had the issue again since the hard power off and reboot.
It is interesting that you had the same thing happen with different software. I will update this thread should the issue re-apprear.

1 Like

Hello everyone!

I have recently experienced the same problem: suddendly I lose connection to the internet. The router remains on. WLAN works and wireless devices are connected. The router isn’t just connected to the internet anymore.

Umbrel version 0.5.1
Rasberry Pi 4 8GB
Connected over ethernet cable
Drive: SSD

This happened yesterday. The bitcoin node app had just finished syncing, it had been running smoothly for about a week. After tuning the rest (mempool, LN, ecc…), I sent a transaction to open my first lightning network channel through thunderhub. 2 minutes later, I experienced the disconnection.

I thought it was the weather, since I have a FWA in a rural area and it was raining.
I decided to switch off the router and the raspberry, then to switch them on again.
It worked apparently. Everything was back online. I opened all the apps again and I went to sleep.

This morning I noticed that the same thing happened again during the night. Checking in the router page and on my PC, I estimate that the problem occurred about two hours after I went to sleep. During the night the router did not reconnect automatically to the internet. The umbrel logs do not seem to help.

I hard-rebooted the router, but I left the raspberry off this time. I am at work now. I’ll check the situation once at home. If the internet connection has not crashed again, I will rule out the weather (still raining hard).

I am thinking about other options, like getting a switch as in the posts above (thank you guys).
In the meantime, I am not excluding other possibilities. For example, could it be an ISP-related problem? I don’t know. I tried to contact the technical support of my ISP, but they had no clue (I just told them about the disconnections, did not mention the pi).

However, it is so strange that the problem emerged after setting up the lightning part (LN and thunderhub) and the explorer part (electrs and mempool). I had absolutely no problem when syncing the blockchain for a week, having just the bitcoin node app installed.
I think I will also try uninstalling the explorer part (don’t know how these app could interfere, but it’s worth trying before buying a switch).

I will keep you updated.

Update 1: weather ruled out. After coming back home, I found that the internet connection of the router had been stable for 9 hours, despite a very bad weather.

Update 2 (sorry I can’t edit the original post): I restarted the Raspberry Pi. For some reason, it could not “start” the external ssd. It is a problem that I had already experienced once during the initial setup, but it did not come up again until now. I solved the problem using a case for a 3.5" drive which has two separate lines for data and power. The Pi has been running smoothly for about 7 days now.

So, summarizing what happened so far, my whole home network crashed twice about a week after the initial setup of the node. It was not the bad weather. After and “hard reset”, the Pi could not read the external ssd. I fixed this last issue by using a bigger case with two separate lines for data and power. Now everything is working again.

I will post again if a new problem emerges. In the meantime, I hope that this experience will help any user having the same problem.