Umbrel going offline

I have this issue recently where node will go offline and i need to restart it so i can see it in the network again.
It usually acts like this every 2-3 days.

1 Like

I’m having this same issue but specifically after I’ve altered something like the alias.

Did you resolve?

Same here, as @The_Lorax says, looks like after the last version is happening like every 2 hours and the node gets blocked or gone offline and I need to unplug and plug it again to restart. Some important points…

  • I noticed the blocks updated are like from 2 days ago (like last Umbrel version update). I usually wait until everything is synced but looks like goes back all the time.
  • I Reflashed the SD as recommended in some other threads, but it keeps happening.
  • Also, using the recommended hardware, exept the case, that is a similar one.

Any help is highly appreciated :pray:
Thanks in advance.

No solution so far.
Tried to reflash the SD but offline thing shows up randomly (sometimes after 3-5 days sometimes can happen same day)

1 Like

Problem didn’t start for me until the most recent Umbrel update. I’m trying the static IP address change via dhcpcd.conf as recommended, but I shouldn’t have to.

Mine is going down approx every 24 hours. We’ll see what happens tomorrow.

Yesterday was a hell for me. Node going down like very 2 hours. So at night I disconnected and this morning plugged back and is working since then like 5 hours.

Some comments…

I was previously connecting through Opera, and now using Safari instead. I realised Opera couldn’t connect to local, and Safari instead was connecting and giving the Error under Umbrel interface. I shot down the node with offered options into the error interface and left it rest the whole night since it was hot (no more than other times, but just trying).

Not sure honestly if it is the cooling down, shutting it manually and running again after completely cooled, using Safari instead Opera or the whole thing together, but is running 5 hours without interruptions.

BTW, I also refreshed the SD a couple of days ago with no positive results.

Cross-fingers :crossed_fingers:

I started having this problem after doing the most recent update, Umbrel Version 0.3.13. It is crashing every day since then.

Same here , before this latest update I never needed to restart it not even once :face_with_symbols_over_mouth: can’t ping it network scanner doesn’t pik it up totally offline till I unplug it

Sorry for the inconvenience guys!

We think we’ve fixed the issue, can you update to Umbrel v0.3.14 and let us know if that does the job?

Thanks for your patience!


Thank You!

Updating it now and will report the outcome.

I’ve updated when the release was available but it doesn’t appear to have fix the issue, since updating i still need to powercycle the pi every few hours, it becomes totally unresponsive, and blind to local network till rebooted :frowning:

Do you use the official power supply? Also, what SSD / SSD enclosure have you?

Yep got the official power supply

SSD: SanDisk SSD PLUS 1 TB Sata III 2.5 Inch Internal SSD, Up to 535 MB/s, Black


Since day one it was rock solid never once had to reboot it until the update that caused the issue, traproot upgrade worked perfectly too.

What’s the output of the following command (execute it in Powershell on Windows, Terminal on macOS and Linux)?

ssh -t umbrel@umbrel.local "cat /etc/dhcpcd.conf | grep denyinterfaces"

umbrel@umbrel:~ $ cat /etc/dhcpcd.conf | grep denyinterfaces
denyinterfaces veth*
umbrel@umbrel:~ $

Could you copy paste the output of the following command to a

ssh -t umbrel@umbrel.local "sudo dmesg"

:slight_smile: Do i need to redact any of that?

Checked again now and the Gui is offline, ip still visible on the network and ssh still accessible, port scan only finds ssh 22 open, results of command showing mostly errors:

[26480.685514] Read-error on swap-device (8:0:286083376)
[26480.685522] Read-error on swap-device (8:0:286083384)
[26480.685530] Read-error on swap-device (8:0:286083392)
[26480.685691] Read-error on swap-device (8:0:286083408)
[26480.685700] Read-error on swap-device (8:0:286083416)
[26480.685709] Read-error on swap-device (8:0:286083424)
[26480.685717] Read-error on swap-device (8:0:286083432)
[26480.685725] Read-error on swap-device (8:0:286083440)
[26480.685733] Read-error on swap-device (8:0:286083448)
[26480.685742] Read-error on swap-device (8:0:286083456)
[26480.691392] Read-error on swap-device (8:0:286083464)
[26480.691415] Read-error on swap-device (8:0:286083472)

swap-device is the ssd i assume?

I believe I’ve had similar issues but think I’ve fixed mine (so far about 24hr straight with no issue). What I was directed to do was use the Umbrel-recommended SSD enclosure w/ cable and this resolved my node acting up.

Previously, I thought I already had the recommended SSD enclosure but turns out I did not. I could swear a couple months ago there was a different SSD enclosure linked to Amazon on the Umbrel-recommended hardware list, but I digress… You need an enclosure with usb c to usb a cord, before I had usb micro b to usb c cord which appears to have been causing the node to work improperly.

Perhaps try to get an SSD enclosure that is usb c to usb a (just the current Umbrel-recommended one). If this is not the issue with your node, then I’m not sure of anything else. I’ll report back if I run into crashing issues again

1 Like

Hi guys

My umbrel was rock solid until the last update 0.3.14. Now it goes offline every 24 hours and I have no choice but to unplug it and plug it back in from the mains.

I use the 8GB Pi 4, 32Gb micro Sd, official power supply and the Crucial MX500 1TB 3D NAND SATA.

This is annoying as I travel a lot and my channels will be down and probably closed if this happens when I am away. Can anyone help?.

I have done whats sugggested above and this is the result - see the paste bin attached.

Any thelp is much appreciated.

Many thanks

Umbrel.txt (60.6 KB)

1 Like