Validating after flashing fails

Hello everyone

I tried severel times to flash umbrel-os-v0.4.1.img on my sd card with the balenaetcher 1.5.122
it loads 3 times the first is the unpacking, second is flashing and the third validating. Validationg goes wrong every time about 9 %. then it says flashing failed

if i just skip the validating it says succesful but it will not work on the raspperry

On the sd card there was a raspbian image on it. I formated the card before i tried to flash umbrel
to make sure that the card isnt defekt i tried another card which was in my gopro
it endet in the same result

What am i doing wrong ? Thx for help

You don’t have to extract the zip file, you can just point Balena Etcher to the zip file. Maybe you should re-download the zip file just in case the one you downloaded was corrupted.

1 Like

Thank you for the Support
I used now the flasher from the Raspberry page it worked fine. I guess i should have reinstall balenaflasher

Good morning. I still have the same problem in the finishing of the validations. I reinstalled the zip file and the BelenaEther SW. Problem still exists. Can you help me with a step further or other site where to download better versions of the SW?
Thanks and Regards,


Hi Umbrel, I suggest everyone using as flasher instead of Belena. This one does work smooth.