Upgrading from a 4gb to 8gb Raspberry Pi Error

Hi -

I upgraded my Raspberry Pi. I tried swapping out only the SD card like I see in some threads but I’m seeing the error below. When I put the sd card back in the old one it works again.

Any help would be great!

1 Like

same bullshit last 3 days with the pi 4 and 0.4.4. Tried about a dozen things but doesn’t work.

I think I resolved it. I went back to my original Pi4gb. I let it boot. Then I went and hit shutdown (wait until done). Then I rebooted on the new one. It took a lot longer than normal but it worked. It also went to a new IP.

:slight_smile:How to set a static IP for Umbrel node

Thanks, I had one set on the original umbrel.

Just pointing out to those making the switch that the new pi will be assigned a different IP.

no luck for me. I’m setting up a new pi 8gb, don’t have another pi. I first get the hard drive disconnected error, then the system service failed error. How can I troubleshoot this!?

P.S - I’m using the power supply that was prescribed.

Update: I also tried to restart by replugging my power supply when I DID NOT know I’m not supposed to do that :confused: so what do I do now ?

@augustus You can reflash the micro SD card then connect everything back, it should work again. The ‘harddrive disconnected error’ might signify a bad cable or in rare cases: a bad USB port, try a different USB 3.0 port (the blue one). If nothing works, try purchasing a different case for your HDD/SSD to see if the issue persists.

Thanks for responding. I’ve tried reflashing SD card multiple times even with different imagers; it did not work. Really hope it’s not a bad Pi in terms of dud ports.

About to order a new case but – when I connect the hard drive to my computer I am able to read and reformat it etc. so does it mean the case is not bad then?
Also, when I connect the hard drive back to my laptop after trying ot get umbrel running I often get a “failed to initialise” error. What could that mean?

My node is up-and-running after I attached the ssd in the black (usb 2?) ports so thanks all for replying and sorry for trying all this dumb shit before posting :confused:

Also how much does that affect my time to sync and/or other stuff you think??