Umbrel v0.5.4 - update not offered by the 0.5.3 Settings section

Hi, I see that there is a new 0.5.4 release of umbrelOS. I am running the 0.5.3 on Raspberry Pi4, but if I click the CHECK FOR UPDATE button in Settings section, the 0.5.4 version is not awailable - it still says “Your Umbrel is on the latest version”.
Is there a bug?

Hey @maravac! Sorry for the confusion, the update will go live within a few minutes!

The button appears, i click, it shows loading progress for a few seconds, and then nothing happens.
It doesn’t update.

“Update failed
Error bootstrapping umbrel server”

Can you try restarting your Umbrel from settings and then trying the update again. If that still doesn’t work I’d love to take a look at your logs to see what’s going on.

Thanks. Updated successfully.

Is it safe to install the update when you are running nodes? Would hate to lose everything and have to start over.

Yes, it’s totally safe! You won’t lose any data at all.

I still cant see the update in the settings (already restarted my umbrel). Also tried to update via console - i received an error.


Hi! i am running umbrel on ubuntu. I haven’t seen any updates yet! does that come later?

Sorry for that, @rene. The update should in fact be available for installations on Ubuntu. Can you please try restarting your umbrel with sudo scripts/stop && sudo scripts/start (from the umbrel installation directory), and see if you can see the update?

Hi! Umbrel has successfully restarted. But still no update. Also when I click on the “check for update- button” it says: “Your Umbrel is on the latest version”

Ah that’s weird. Are you on 0.5.3 currently? If so, you could try updating by running this command inside your umbrelOS installation directory:

echo '{"state": "success", "progress": 100, "description": "Successfully installed Umbrel v0.5.3", "updateTo": "v0.5.4"}' | sudo tee statuses/update-status.json && sudo scripts/update/update --ota

Note: Do not run this command if you’re not on 0.5.3 as it would skip important migration steps for previous versions, resulting in a corrupted install.

Yes, im on 0.5.3. and the Skript runs without any Problems but i still be on 0.5.3?!

is this right? (updateTo 0.5.3):

 ....rel v0.5.4", "updateTo": "v0.5.3"}' | sudo t....

thx, René

Ah sorry @rene, good spot. My bad, I switched the version in the wrong place. Here’s the correct command:

echo '{"state": "success", "progress": 100, "description": "Successfully installed Umbrel v0.5.3", "updateTo": "v0.5.4"}' | sudo tee statuses/update-status.json && sudo scripts/update/update --ota
1 Like

Excellent! now I’m on 0.5.4! Thanks a lot for your help! :grinning:

1 Like

Working for me too! Thanks.

Not sure how to solve it - can someone help?