Umbrel not updating to Umbrel v0.4.17 in Linux set up:

Hello All,

Thank you for offering us this great system. Can someone please tell me why when I click on the update button it starts the system update and says it is all completed but then refreshes to show it has not been updated and is asking to update as if I have not even started the update? Using Firefox’s latest version on more than one device but the same result, etc… Maybe because I am running Umbrel on Debian Linux and not on a Raspberry Pi 4?

Please let me know if you have any ideas?

Thank you.


Read in troubleshooting manual the section how to update manually.

The instructions for standalone Debian are separate, so pay attention to details.

Hi DarthCoin,

Thank you for that information, I really appreciate your response.



1 Like

Keep in mind: before updating Umbrel, do the OS update. All Umbrel docker packages depends on those OS updates.

Hi DarthCoin,

Thank you for the updated information!



Hi Again DarthCoin,

I followed the instructions but when it came to updating the umbrel OS in Debian this is what I got?

sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8
./scripts/update/update: line 44: git: command not found
./scripts/update/update: line 47: git: command not found
mv: cannot stat ‘/tmp/umbrel-update//info.json’: No such file or directory
jq: error: Could not open file /tmp/umbrel-update//info.json.orig: No such file or directory
Update path doesn’t seem to be an Umbrel install.

If you have any ideas please let me know.

Thank you.


Maaan, but you didn’t changed to latest version 0.4.17 !
Pay attention to details. That is a generic command, you need to adjust it.
Also the command MUST be run inside umbrel folder.

Hi DartCoin,

Thank you for being so vigilant regarding my issues.

I reread the error after running the update command for linux systems and then proceeded to install git-core, which I did not realize my OS did not have installed.

so then I accidentially ran this command in the terminal

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8

Which is the one normally used for raspberry Pi 4’s and it started and completed itself and said that it had updated itself but when I logged into umbrel from another pc it still says:

[Umbrel v0.4.17] is now available to install [Install now]

So I guess it did not really update itself?

Any Ideas please.

Thank you once again.


That command is for both RPi and stand alone OS. You just have to replace 0.4.8 with 0.4.17 and run the commend FROM inside the folder /umbrel. That’s all.
In the troubleshooting manual I specified step by step what to do. Please follow them exactly.

Hi DarthCoin,

Thanks again for sticking with me here.

So I ran the linux command to update (cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8) and now in the umbrel settings it says;

Umbrel Version0.4.8-build-dae920c so it worked after all, thank you.

I will reread the instructions you sent earlier to update it to 0.4.17.

Thanks again!


Hi again, again,

I saw this at the end of the manually updating information is this the step you are refering to?

C. Just re-flash the mSD card with the latest Umbrel OS version, like you did when you install it first time.

Thank you


The command you used to install 0.4.8 should be changed to use 0.4.17:
cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.8

change that number on the end to 0.4.17

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.17

Then you’re done.

Hi DarthCoin,

I ran the update form inside the settings tab in Umbrel and this time it worked without running the manual command! If I have any similar issues in the future I will run the command you mentioned above.

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.17

But will change the version number at the end of the update command to the latest version available.

Thank you for your patience and persistence.



Sorry I did not notice that you were not DarthCoin.

Thank you for all of your help!



Don’t worry about it, lol. I’m glad that you were able to get it working now.

1 Like