Umbrel stuck on latest update + can't ssh into node either

Hey Umbrel community,
my node is stuck for 5 days now while updating. I also cannot ssh into the node anymore.
Anybody has any ideas how to solve the issue? Everything is running on a TBM (bitcoin machine).

Can you try to SSH via the node’s IP?

You can find this in your router administration page’s connected device list or user Angry IP scanner to scan your network, the IP will display to device with hostname umbrel.local

Then try to ssh like this: ssh umbrel@YourNode'sIP

You can try to then use the command: sudo reboot

It may also help if you’d like to reply with the output of this command:
tail -n 100 ~/umbrel/logs/karen.log

This will let us know if there is an actualy update error or if it’s progressing.

We’ll only want to run this command if we determine an actual update in progress error, otherwise this deletion command can cause issues, but once we get the update log and see an in progress error we can run this:
rm -f ~/umbrel/statuses/update-in-progress && sudo reboot

If after ssh attempts and if we cannot access the UI either, this is a last resort if we cannot reach the node, is unplug and replug the device. Then hopefully this will allow us to reach the node via at least SSH.

Let us know what you’ve tried so far and we can continue to troubleshoot.


Hey Jim,

thanks again for your reply. I used a different solution as I was not able to fix the node.

I tried again and unfortunately it is still stuck. I was able to access the UI for a few moments, but then it starte to reboot.

Should I share some screenshots withy you?
The sudo reboot command did not work + the other two commands you shared with me also did not have any impact. tail -n 100 ~/umbrel/logs/karen.log
rm -f ~/umbrel/statuses/update-in-progress && sudo reboot

I am asked to type in the password for the node. I have it and type it in, but mostly the terminal does not accept it.

I am not sure what I am doing wrong to be honest.

Thanks for your help.


Hey Jim,

this is what I get atm.

The default interactive shell is now zsh.

To update your account to use zsh, please run chsh -s /bin/zsh.

For more details, please visit

Alexejs-MBP:~ alexejluecke$ ssh umbrel@

umbrel@’s password:

Linux umbrel 5.10.63-v8+ #1459 SMP PREEMPT Wed Oct 6 16:42:49 BST 2021 aarch64

The programs included with the Debian GNU/Linux system are free software;

the exact distribution terms for each program are described in the

individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent

permitted by applicable law.

Last login: Fri Apr 7 16:21:05 2023 from

umbrel@umbrel:~ $ ssh umbrel@

umbrel@’s password:


Permission denied, please try again.

umbrel@’s password:

AmongstoPermission denied, please try again.

umbrel@’s password:

Aumbrel@ Permission denied (publickey,password).

umbrel@umbrel:~ $

I did not post my PW here. Not sure why permission is denied. Also I have no idea what to do next.