Umbrel stop working suddenly

I have been running my Umbrel for several months without issues, did all updates until the latest version with new interface. Last time I recall using Umbrel was to update some apps, including Lighting. I’m pretty sure it was working fine after it.

Today I tried to connect and had an unreachable error on Tor. Try in local, same. Look into my router, Umbrel/RasPi not visible. Everything is blinking normally, pull the plug, reboot, it looks like it boots but it never get an IP on the network. Ethernet cable LED are ON both on the RasPi and switch.

Not sure what do to next? I tried to find similar case but everyone with boot issues seams to be able at least to reach it to get a log or something. I’m completely blind and I don’t think I have a micro HDMI cable to see what show the P, and even so I’m not sure it will help me, other suggestions before I buy the cable?

EDIT: still trying to figure out what’s going out. I tried to plug the SD on a PC, it looks ok. I plug the SSD, everything looks OK as well (I did backup again the channels just in case).

I try to flash Umbrel OS to a new SD but I didn’t start it up as it says it will format automatically my SSD, which should be ok so I don’t want to start over everything.

What should I backup from the SSD beside the channel file? I have many app, like Sphinx, Samourai Dojo, not sure if I should backup more just in case.

EDIT: I got an answer from GitHub, for other wondering, if you have a working install of Umbrel on your SSD and flash a new OS on the SD card (or on a new SD card) it will just detect the install on the SSD and start from it. The only thing that I notice changed are the SSH key to connect locally. However I still have some channels marked as disabled by Amboss, not sure if it’s a real issue or just a delay for update all channels status.

My question about backup of other apps is still open, I will try to investigate to get covered in case I have more deep trouble once.