Starting Umbrel Issue

Using Umbrel, RasPi 4, SSD, connected via ethernet

I have taken all the steps via umbrel website— and now I am just stuck at the “Starting Umbrel” loading screen

Any suggestions for me to get past this step?

Hi, I’m having the exact problem as you. did you get any support for a solution? TIA /Tim

I had this issue and it turned out that the SSD wasn’t connected well. You can check if that’s the issue or not by ssh’ing into the umbrel and running the debug script (let me know if you need the steps for that)

If you could provide those steps, I would appreciate — I am learning about ssh, but still a bit green

see below Tim, Sovereign is trying to assist with this issue

Sure, no problem. Open a terminal window on your computer and type “ssh umbrel@umbrel.local”, password should be moneyprintergobrrr. Then once you’ve connected, you can run “~/umbrel/scripts/debug” and it will print many lines of logs. When I encountered this error, near the top there were some lines that indicated that the SSD failed to connect, and I just had to mess around with the enclosure a bit. IMO the enclosure they recommend is not great and seems like others have the same issue. But, you may be encountering a different issue, in which case you can copy/paste the log output to the telegram channel, where more experienced users may be able to narrow down the issue.

Just to piggyback on this post…

–for me, I had to type “ssh -t umbrel@umbrel.local” to be able to ssh to my umbrel. I am on a Mac using ZSH for a terminal, so I don’t know if that’s the difference

–the previous umbrel versions used moneyprintergobrrr as the default password, but looks like the new version 0.4.1 uses the same password you set up to log into your umbrel.local page

–if you debug using “~/umbrel/scripts/debug --report” it gives you a longer debug list that’s easier to read.


I had a hard drive go bad on me too, and when I ran that report the error was listed under “External storage service logs” and it looked like this:

It now looks like this:

Thanks a ton Cam.btc

What did you do to remedy the External Storage Mounter

I have the new verison of Umbrel, but I never even got to the username/password page so I am wondering if i still use the default password—

I am also using MAC— for some reason when i start typing the passsword into my terminal it denies access before i even finish typing… have you ever had that issue?

Thanks Sovereign— im going to be trying this today

Any tips on when you messed with the SSD enclousure? I have the reccomded one as well, and im wondering if its the same issue

Here is what My debug script gives me

This script could not automatically detect an issue with your Umbrel.

Please share the following links and paste it in the Umbrel Telegram group ( so we can help you with your problem.

tail: cannot open ‘/home/umbrel/umbrel/scripts/…/logs/memory-monitor.log’ for reading: No such file or directory

tail: cannot open ‘logs/karen.log’ for reading: No such file or directory

umbrel@umbrel:~ $

I’m not an expert (/oblig) but looking at your debug report it looks like your external drive is good because it said mounted successfully.

I haven’t heard of why it would deny access before completing the password, but I have heard of it denying access … and usually it’s after you reflash the microSD card with the umbrelOS. You’ll get a scary error message that says DNS in it. If that is the case then that’s caused because the first time you ever ssh into umbrel you typed “yes” to an agreement to put umbrel in the ‘known host’ file on your computer… and now the host has changed, so your comp thinks something fishy is happening. If that’s the case then follow the steps on this community board.

On your debug report it kinda looked like it wasn’t connected to TOR tho. Maybe try ssh back into umbrel and see if you’re connected to the internet by typing ping (which is Google) to see if your node has internet. If it doesn’t then you may have to mess with the router … and if that’s the case you can go to this community board for help on that.

password issue is solved-

I will try ssh back in and check the internet

This is my most recent debug script – i have reflashed a couple times with no luck

Thanks for responding— I will get this figured out eventually and looking forward to being operational’

This script could not automatically detect an issue with your Umbrel.

Please share the following links and paste it in the Umbrel Telegram group ( so we can help you with your problem.

tail: cannot open ‘/home/umbrel/umbrel/scripts/…/logs/memory-monitor.log’ for reading: No such file or directory

tail: cannot open ‘logs/karen.log’ for reading: No such file or directory

Pinged the Internet using ping and it responded— so all good there.

Still not sure quite what the issue is

I ran a debug report and mine has a lot more info beginning under “karen logs”. the Bitcoin core, TOR, etc all have a bunch of logs under it.

It looks like your memory usage is 147megabytes while mine is a minimum of 2GB and sometimes over 3GB. If you have internet, and your external SSD/HDD is good, then I’m wondering if your umbrelOS on the microSD card isn’t jacked. If you have no other info on it and never got to even log on then maybe you can reflash it?

I’ve reflashed mine before, but that was when my external drive was already messed up, so I don’t have experience of it not messing with the blockchain sync or not. It makes sense that it would not mess up your sync tho… at least in my mind. If you do that then keep in mind you’ll get that DNS error thing I was talking about earlier when you try to ssh back in, so you’d have to go to that post I linked to to remove umbrel from the ‘known host’ file (not hard). If you have zero BTC or any other info tied to the node yet then just start new… if you do have BTC in there then make sure you copy your seed phrases.

Thanks Cam-

I have not even gotten to the username/password start page, much less the blockchain sync

Just stuck at “starting umbrel”

I am going to try and reflash again and see what happens-- thanks

@cam.btc @timsmig @sovereign

Guys I am IN! so pumped and thank you for all the help— it was quite a process but I am good to go now!!

I beileve i just had to reflash again (did it like 4 times) but I also ran a command via suggestion from the telegram , see below

sudo systemctl stop umbrel-startup.service && docker system prune --force --all && sudo systemctl start umbrel-startup.service

I cant be 100% sure if it was this command^ or just the simple reflash but i am up and running

Thanks to everyone for all your help


awesome! happy to hear it :+1:t3:

Congratulations! did you reflash the ssd & sd?

1 Like

I’m happy to report that I am in too. (>27% loaded as of the time of this writing)
Thanks to help from a group of folks from all over to include Kody from Pomp’s Crypto Academy and @balconynode on the Umbrel Community telegram support thread.
we too reflashed the SD & SSD numerous times. and we also added *supplemental power to the SSD 1TB card instead of running power thru the Pi. I personally feel that may have been the solution.

@cam.btc @sovereign @NBABTC


That is awesome! – I am around 60% synced

I flashed only my SD, and that seemed to work for me