" Dependency failed for... "

Hello everyone,

I have a problem with my Umbrel. It doesn’t work anymore. It broke down about 1 month ago. I’m looking for help. (I’m a computer noob).

Here’s my configuration:

  • Raspberry Pi 4, installed in an Argon one M.2 case. The OS (Umbrel) is on a SanDisk Ultra 32 GB micro SD HC I card. The data (including the bitcoin blockchain) is on a WD BLUE 3D NAND 1TB M.2 SSD.
  • I don’t know the exact version of my Umbrel, but I used to update it quite regularly (checking maybe once every 2 or 3 months). As for the apps installed from the Umbrel store, I had a complete bitcoin node, BTCPay server, Lightning Node, Samourai Server, Electrs… and I think that was more or less it!

I’d been letting my Umbrel run on its own for about 2 years (?) when I realized, about 1 month ago, that it wasn’t working anymore. I couldn’t reach it from its network address. I restarted it several times, but nothing. More to the point: the Raspberry turns on, there’s an indicator light on its case and the sound of the fan on start-up, but the yellow and green lights on the ethernet port remain fixed. Since there’s an HDMI port on the Argon box, I disconnected the device from the network and launched it on its own, connected only to a screen. Here are the photos I took during the launch. Being a computer novice, I’m unable to understand where the error came from… and how to fix it.

I’d like to thank anyone who can help me!

Hi @Billy, can you SSH back into your Pi, like you’ve done just here, and run the following. Thanks

sudo ~/umbrel/scripts/debug

Hi @smolgrrr ,

I can’t reach my Pi in SSH via my regular network.


ssh umbrel@
ssh: connect to host port 22: No route to host


Rebooting my Raspberry Pi again, I was able to take another picture of what appear to be error messages…
“blk_update_request: I/0 error, dev mmcblk0, sector […]”

Could my micro-SD card be dead? Or is it something else?

Too hard to say just yet, unfortunately the Pi console over HDMI won’t help us much.

With the Umbrel on, can you trying scanning your local network for IPs the Umbrel might be under now- it could have changed. You can use https://angryip.org/

I answer myself (with much delay).

So, I’ve solved the problem. It was indeed a problem with the micro-SD card.
I bought a new micro-SD card, reinstalled UmbrelOS on it (following the procedure indicated here: « Install umbrelOS anywhere for free. » > « Install on a Raspberry Pi 4 » Umbrel — The ultimate home server and OS for self-hosting ), inserted this micro-SD in my Raspberry, plugged it back into my router as before, then switched it on. And it worked! All my applications and data were recovered without a hitch.

Well done to the Umbrel team for designing such a simple and effective program!