Umbrel not starting up

Hi there,

once again for the sixth time know my node sadly quit working.
This time the node won’t even start. Just showing this:

What can I do?

Thank you!

PS: After recovering the data I will probably sell the hardware and buy everything new to hopefully finally get rid of all the problems.

Hey J0nsan are you on a Pi 4 and have tried reflashing already/replacing MicroSD card? After reflashing I’d run command: sudo reboot

Steps on relfashing here: under How to install
Steps on How to SSH and Generating Debug Logs via the terminal are here: Official Umbrel Troubleshooting Guide and FAQ

Let me know what else you’ve tried so far and happy to further assist

Hi Jim,

I always reflashed it the last times but never replaced the sd card. I just ordered a new one and will try as soon as I have it.

Until now the only thing I changed was the ethernet cable. So I guess I will have to try out one thing after another. Problem being that the issue only appears after about 3 months. So that will be a long process.

Regarding data recovery: Do I have to safe anything beforehand? The last channel backup I have is about 3 months old, but I think no channels where open. But I have some funds on the node.


Hey @J0nsan when you’re ready and perform an automated recovery it will close all channels and return all funds back onchain, this is the safest and most reliable way not to lose funds. Once you plugin your 24 words into lightning node app it will also allow you to automatically choose your most recent backup file from the interface so no need to upload anything manually, I would advise on clicking the most recent automated backup to avoid any old channel states being broadcast, and making sure your seed phrase is only active on one device at a time. That process is demonstrated here:

If you had a c-lightning node that process is different, if you had any files you can copy all contents from the /downloads folder, and depending on what application you were using they may have had other backup files you can generate. Please let me know if you have any other questions happy to further assist!

I kind of did a stupid “oopsie”. I have two 24 words phrases and don’t know which one is the correct one. Is there a way to get the 24 words via ssh (I can still access the node that way) or can I change the 24 words easily if I notice I put in the wrong one?

Any Ideas?

After you login with your password via SSH you can see the seed phrase with this command:

sudo nano ~/umbrel/app-data/lightning/data/lightning/state.json

If you believe you used the wrong seed, you can have only one active at a time so you’d need to delete Lightning Node application and then reinstall and click Recover Your Previous Node with the other one to try…

For some reason even after flashing a completely new sd card its still stuck the same way like my original post. What can I do more? Delete the SSD as well?

Let’s try this,

Run this command:

sudo scripts/stop && sudo rm -f ~/umbrel/statuses/update-in-progress && sudo scripts/start

Wait five minutes and then let me know if you can now successfully access your dashboard.

It gave me this error: sudo: scripts/stop: command not found

write it like this:

sudo ~/umbrel/scripts/stop && sudo rm -f ~/umbrel/statuses/update-in-progress && sudo ~/umbrel/scripts/start

Let me know the current state of the issue and we can further troubleshoot

Update: I bought a new sd card, reflashed it and did the IBD. The node worked fine for about 1-2 days. Now the mempool app always gets stuck (right now last block is shown 19 hours ago) At the same time the Bitcoin Node App shows the current block height as it should be.
What is happening?


Umbrel debug info:

DMESG log: