Adventure in Umbrel Restoration

Hey all, I am hoping to get some ideas for where to look next at recovering funds from an Umbrel Node that went down.

For reference, here is my node on 1ML.

Here is my timeline of issues, roughly:

  1. Node went down last week, I promptly spun up a new node and found the on-chain balance intact.
  2. It took me quite a while to start a channel recovery, but I was finally able to do it. The key to resolution here is that the backups I created were in RTL. Once I figured out where to place that backup file on an umbrel, I was able to get 10 of 12 channels to close. I assume the other two were offline at the time. You can see this change if you look at the info at 1ML.
  3. Now, here is where the real trouble starts. Another issue occurred with the node, apparently, and all balances started showing as blank. In addition, downloading the blockchain was not progressing for over 8 hours or so. Since my last attempt at recover went fine, I made another fresh install.
  4. Now to the current problems, I think there are two separate issues I am facing:

Umbrel Won’t take the seed, doesn’t create a seed file

I’ve been through multiple re-flashes of the SD card, and multiple formattings of the SDD. I’ve even purchased all new hardware. Every time I put in my seed, I immediately get an error.

Now, at this stage, umbrel won’t let me proceed. If I re-enter the seed, make an edit, or do anything else, it says that” user already exists.”

So, when I refresh the page, I get what seems to be a synching node. Except, there is no balance.

This persists after multiple re-starts with fresh installs, and even new hardware (went to the shop to get a new Pi and new SD and SSD).

Following a lot of troubleshooting, I came across a way to reset the user data of the node, among other troubleshooting tips. This includes the SSH command sudo rm ~/umbrel/db/umbrel-seed/seed

Turns out, I don’t have this file. It doesn’t exist: “no such file or directory”

If I spin up a fresh node, without the recovery seed being used, this file does exist. Something about my seed, or my seed recovery procedure is causing this file to not be created, over and over.

I am very confused by this, as it worked the first time I did the recovery (seemingly), but not since. Any ideas on what to try next?

Recovery via Blue Wallet, Zap Doesn’t help

Along the way, I found that Bluewallet will take the AEZEED used by Umbrel. While I can see some of the UTXOs from the wallet and can match it up with my recollection, but not all of the data is there. The latest transaction in the bluewallet shows only the change from my last channel opening transaction (and not the input leaving the wallet). It does not show UTXOs from any of the recent channel closings.

You can see the channel closings in the 1ML above, none of these are shown in Bluewallet.

This leaves a small portion of the balance that should be available accessible by Blue wallet. Any ideas here?

I’ve tried Zap as well, but I can’t seem to proceed past the “fund your wallet” page. Any other recovery options for the on-chain balance at this stage? Are there alternative methods to getting the last two channels closed if I can’t get an umbrel up with this seed?


Additional Detail on Problem 2

I’ve gone so far as to search my xpub in blockonomics (I know that isn’t great to do, but I am going to torch this thing and coinjoin as soon as I get it resolved).

Blockonomics shows a zero balance with no transactions after May 15, which disagrees with Bluewallet (where I got the xpub from), which disagrees with what I did with the node. There should be multiple on-chain transactions this week. So confused.

Update on Problem 1

I’ve created 2 new seeds, and tried to restore both multiple times. No success. I get the same error. Still have a missing seed. Something about what I am doing means that umbrel cannot restore from any 24 word seed.

Same thing happens when I type nonsense in for recovery words. I refuse to believe I am this bad at writing down words and typing them in again.

Seed imported in BW showed some old transactions so seed is ok. Thing is when you restore from channelbackup, channels are forceclosed and your funds are locked two weeks as I remember it right. Until this time you will not see funds returning to your onchain wallet.

That’s the only thing that gives me comfort here. But the data on BW seems incomplete, even before the recent channel closures. For example, the most recent transaction shows only the change retuned to the wallet, and doesn’t count the input utxo as part of the Wallet.

Yes, I have same feeling when imported umbrel seed in BW, some kind of incomplete data, but amount was right as shown in umbrel. At least you know your seed was written down right. I don’t know why umbrel is not able to recover seed. Hope you will get your funds back.

Hey all, I’ve figured out what is going on with problem 1.

Each time I spun up a new node, I was forced to use the “back” button at a certain point. This is because my computer was suggesting a password, and somehow was clearing the password field.

I would get past this by typing my password again, no biggie.

Well, it turns out the back button is kryptonite for seed restoration.

This was where I found someone reporting something similar.

Balance from force close is locked in limbo and will return to your on-chain wallet. If you have seed you are good. When did you do restore from SCB? 2021-07-30 05:41? If so, just wait.

This is one of your closing transaction.

There you can see lock time. I’m not sure how calculate exact maturity height from that number. If you would have correctly restored node, in you can run lncli pendingchannels. In list of channels there is block till maturity and maturity height. It is time when your funds will return. Default should be 2016 blocks = 14 days from force close. Hope this help and sorry for my English.

So, we just finished syncing, and it seems I am going to run into every issue I’ve come across researching how to restore my funds.

At the moment, we just got to full sync. Still 0 funds showing in the on-chain wallet.

In addition, when I try to generate an address, I am getting a blank address area. It looks like this.

I see potential solutions there. One involves the v3_onion file, which doesn’t seem to apply, as mine is of size 99.

I am a bit nervous about staring my user data all over again, considering I just got the restore to work, but that might be what I do tomorrow to see if a fresh scan can be done.

BTW. I am pretty certain my seed restore went well, as my public address for my lightning node is the same as it was before.

Is there any other way to force a rescan of wallet transactions with Umbrel? I found something relating to land -reset-wallet-transactions, but I can’t seem to figure out how to call this command via SSH.

Just tried the rescan options from this:

It doesn’t seem to have worked.

Still 0 balance.

one more note

When I look at the LND logs, it is only scanning for 31 addresses, which isn’t enough. I can tell because of what blue wallet is telling me. Any way to get LND to scan for more addresses when I do the -reset-wallet-transactions command?

I also though I would try the channel backup again, as there is still one more channel open. I figured maybe the node would see a new address closing. But I can’t do that, I get a 404 error in RTL. I think this tells me that LND is still messed up somehow. I am pretty close to wiping it once more.

Funds are Safu, mostly!

I have finally been able to get all of my on-chain funds displaying in the umbrel UI. The last set of issue I had related to having LND in a weird state of some kind (technical detail I obviously understand really well). So, I reset the user data one more time on the umbrel (without wiping the SSD). You can see (how to do this here.)[]

I deleted one of my comments about the funds being in state unreachable by my private keys after closing. It turns out that my node new how to get to these after restoring from seed and doing the channel backup procedure (even with an old channel state before the close).

This was a pretty nerve wracking event, but I have a lot of confidence in doing it again, as I sure learned a lot!

Thanks to everyone who reached out to help!


Oh, the reason I said “mostly Safu” is that there is one channel that is still unreachable, presumably because my peer is offline as well. Will keep pinging it to see if something shakes out, but for now, I’m happy with 90% of my funds!

Question from a non-programming noob to LN. (Programming an alias for my node was complicated!)

If my Umbrel node went down, would it be possible for me to restore my funds?

Is there a simple way to prevent the amount of effort you required to recover your funds?

This might be a LN deal breaker for me, as if it is beyond my capability to recover the funds, or there isnt a simple way to prevent node failure issues, then I’m not sure if its worth the risk.

1 Like

I think I got pretty unlucky. To boil down the issues I had:

My original hardware failures occurred from a loss of power, I am relatively sure. This kicked everything off.

Then, I ran into a bug with the back button thing. If I had been using a browser with a less aggressive password manager, recovering on-chain funds would have been a breeze. And it was as soon as I switched.

I am not sure about the last issue. I think I had another power loss while I had everything out and about in troubleshooting mode (someone pulled the plug). LND got in a bad state, which really required just another recovery.

At this stage, things are humming along. I learned that I need to make my setup more robust to these kinds of power disruptions though.

Hey fireworksurprise, I have read this thread with particular interest. “Recovering” is my number knowledge gap to make serious use of Umbrel and the suite of apps that go with it.

I need a Bitcoin Core Node that I can recover my funds to be “top security” before I can add it to Security model. Which I want to do.

fireworksurprise, is there a way that I can have you recount a “step by step” instruction that we might be able to use and point to, for the future in this Community Knowledge Base? A known working Recovery Procedure. .

I would also like to create a “teaching criteria” for this subject.

Thank you very much, Love ya baby. :slight_smile:
Niles Anders.

Hey @EscapeVelocity, really not sure that I am the “step-by-step” recovery guide kind of user. My knowledge of the subject is fair to good, but I am no expert.

Just about everything I did to get it working was found here.

The problem with troubleshooting tips like that is that there isn’t a context as to why each of those items may be the next thing you should try. In my case, I just had to trust that I had all of the data I needed to restore.

With comfort that this was the case, I just made edcuated guesses about what was going on and tried things.