Umbrel is Running and dashboard is ok but ₿ node is blank

Rasp Pi
Umbrel 0.5.2

Have restarted and reflashed but still the same.
Looks as if the blockchain is synching but no progress is showing. ALso the other apps are not connecting: mempool, specter, lightning, etc.

Will the issue fix once the blockchain is synched?

Hi Catoshi! We’ll want the node to be 100% synced, to avoid having to resync the full blockchain let’s first try to simply reboot the node from the User Interface by just going Settings > then click Restart. After some time, let us know how this goes.

Please feel free to also post your debug logs (Settings > System > Troubleshoot) as well and anything else you’ve tried so far and we can further troubleshoot!

1 Like

Ok, thanks fo the attention.
I’ve tried the restart and it looks like there’s no change.
I’m also getting the change SD card notice, I have changed micro SD and reflashed but the warning keeps popping up on start up, looks like a bug.

Debug log seems ok, attached below.

umbrel-1667242007024-debug.log (26.4 KB)


Nothing changed and I decided to download the Blockchain again.

Just install all apps to delete old and reinstall Bitcoin Core and it starts again.
Currently on 28% been going about 15 hours.
It’s slow but feels good to see I’m moving towards a solution.

Did this work for you?
Similar issue for me. LND Wallet said password wrong, which I unlocked / changed password, with same issue.

Bitcoin shows same screen as your screenshot.

Starting to think it was bitcoin RPC password issue perhaps - if your works, I may follow suit.

1 Like

I have the same issue, after umbrel update, damned !

1 Like

Having exactly the same issue.
Bitcoin Machine device, screen on the node appears to be functioning correctly.
Connecting via ethernet.
Along with the Bitcoin Node screen not loading, BlueWallet LTN does not load and indicates “error”
I’ve restarted the node as indicated in first reply, no change
Apparently as a new user I cannot upload my Umbrel log

Any help would be greatly appreciated, TY

1 Like

If you open RTL does it tell you wallet is locked?

That’s where I got to, still have same issue.
I managed to unlock lightning wallet and change password, but I think same issue is with bitcoin app too.

I’m guessing I can change that password in bitcoin.conf perhaps, but cannot find. it in Umbrel.
Hoping someone can give some good pointers here. I don’t want to delete it and start again :roll_eyes:

I have a Similar issue. Umbrel had an update and so I updated, ever since then, when I open the bitcoin node app it just hangs just like the picture from the original post. I have tried restarting everything several times and I have read thru debug files and in the
debug.log for bitcoin I get this:

2022-11-09T00:34:09Z init message: Verifying blocks…
2022-11-09T00:34:09Z Verifying last 6 blocks at level 3
2022-11-09T00:34:09Z [0%]…LevelDB read failure: Corruption: not an sstable (bad magic number)
2022-11-09T00:34:09Z Fatal LevelDB error: Corruption: not an sstable (bad magic number)
2022-11-09T00:34:09Z You can use -debug=leveldb to get more complete diagnostic messages
2022-11-09T00:34:09Z Fatal LevelDB error: Corruption: not an sstable (bad magic number)
2022-11-09T00:34:09Z : Error opening block database.
Please restart with -reindex or -reindex-chainstate to recover.
2022-11-09T00:34:09Z Aborted block database rebuild. Exiting.

I have no idea what that means. I have tried resolving it. I have tried to reach out to the Umbrel team and nothing. I get that this is a in development project and comes with warnings, like hey be careful we might bug out. But I don’t understand how the Dev team is actually going to release an update that just destroys a perfectly functioning node. Ran my node for 2 months without an issue and this update just bugged it out. Might try out Citadel if I cant get this issue resolved, Cuz the devs on this project leave a lot to be desired. They need to be better at testing updates before just releasing them to the wild.

1 Like

Same issue running Umbrel 0.5.3.

Looks like this happenend when upgrading to Umbrel 0.5.2.

I had to delete all the apps one by one, checking to see where the issue was.
I got down to bitcoin and blockchain explorer, and still there was an issue with RPC connection to bitcoin app.

I think if there was a bitcoin.conf file to alter, I could have corrected the password and user name in there, but I couldn’t find it. ( Closest was a .env file that looked to be importing from somewhere perhaps? )

Anyway, I backed up my channels, deleted all the apps one at a time, then reloaded them.
If you do that, make sure you have your seed and channel backup ready to re-install after the initial blockchain downloaad.

It was a right pain in the *rse, and time consuming for what should be an easy fix, but it was the only way I could work it out as a relatively non-tech operator.

1 Like

Here is a fix for the ₿itcoin node appearing as blank/not loading and causing issues for all dependent apps…

After checking logs likely you may see a line that shows “Error: Invalid or corrupt peers.dat”

What you can do is SSH into your Umbrel and first stop Bitcoin:
~/umbrel/scripts/app stop bitcoin

Then you can delete the peers.dat file (removing or renaming also works):
rm /home/umbrel/umbrel/app-data/bitcoin/data/bitcoin/peers.dat

(If the above command works it just sends you to the new line, sometimes this is confusing but that means it was successful otherwise if you run it again you’ll see it now displays “No such file or directory”)

Then start Bitcoin again:
~/umbrel/scripts/app start bitcoin

Then please wait at least 5 minutes, it can sometimes take a little longer.

Now finally reload your dashboard and you will likely see your Bitcoin Node app has begun to synchronize once more, hopefully closer to 99.8% and only take less than < 1 hour to finish.

Now all your apps will work normally again, including Lightning Node, and this also should fix the issue of Ride The Lightning appearing with the wallet locked error as well once Bitcoin Node app is done resynchronizing. If this doesn’t work or you experience any other errors please share and we can continue to assist!


This worked for me.

Thanks a bunch, Jim.


Worked for me as well Jim. Thank you.


Works for me also Thanks!!!

1 Like

The only thing that worked for me was downloading the entire blockchain again. Took about almost a week, but it’s working fine now!! Good luck.

1 Like

My fix worked, but was very radical. Someone else has posted a fix through SSH (above)

There are a few fixes here

Now I see you did the same as me, but gave a more detailed guide. Nice one

1 Like

Worked! Thanks!