Umbrel broken after 1.0 upgrade

My Umbrel has been running like a champ for months. For the 1.0 upgrade, I followed the instructions:

  • shut down Umbrel
  • pop the power cord
  • pop the SD card
  • use Balena to etch the new OS onto the card
  • pop the card back in
  • apply power

Now it’s completely broken. I cannot access via HTTP or SSH even though my router shows it attached to the correct (static) IP.

When I attach a monitor and keyboard and mouse, upon power up I first get a screen with four big raspberries and the bootup log scrolling really really fast.Then it goes to an all-screen terminal. It says

  • umbrel login
  • a few seconds later a couple messages about system.journal
  • during this whole time it is completely unresponsive to keyboard or mouse input
  • after about a minute, a stream never-ending of messages begins. Dozens of different ports are named as entering the disabled, forwarding, or blocking state. This just goes on forever. Still no response to any keyboard input.

On the ethernet port, the yellow light is steady and the green light is flashing. The SSD light flashes like normal. Router says it is connected. But there is no way of accessing it, either over the network or via a keyboard and monitor.

Is there anything I can try besides reformatting the SD Card (losing everything AGAIN) and re-etching?


I re-etched the SD card with my windows laptop, just to be sure, and let the Pi run all night. Same problem. I also tried booting the Pi without the SSD, same problem.

Then I put the RPi OS back on the SD card. It comes up fine. Then I re-etched again the Umbrel OS onto the SD card. I plugged my keyboard and mouse into different USB ports and this time I was able to log in. On the terminal I see only a command line, and I was able to log in with umbrel/umbrel. However, I still get the endless series of port messages as shown in the screen shot.

Still “no route to host” when using the IP address that the router shows the Pi connected to.

Bleh, it might be this. DeskPi Pro v2 Case - fan doesn't work But the script way of installing Umbrel isn’t ready yet for 1.0.x… “Coming in April 2024”…