Transaction not found?

Hey guys - I’m trying to send some on-chain funds from my Umbrel to a hot wallet. I initiated the withdrawal yesterday. When I use my Umbrel to check the transaction status at, it shows up. However, if I search for the same transaction idea without using Umbrel ( in a normal browser), it says “Transaction not found.”

I’ve sent quite a bit of funds from my Umbrel but have never seen this before. Any ideas / suggestions?

Screenshot from regular

Screenshot from via my Umbrel:

Hi, I have just had the same issue. Moving on-chain funds to a mobile wallet from Umbrel, funds didn’t appear on my Mobile wallet so I checked Mempool and I have the same Transaction not found notice.
My Umbrel is still syncing, but I have received funds fine, this was the first time I tried to send funds.
Transaction has just been received on my Mobile wallet

1 Like

Hmm mine is still having the same issues…

check if you find the TX it using the command line:

~/umbrel/bin/lncli listchaintxns
1 Like

Yes, it shows up there. However, if I copy the tx_hash into any block explorer, it doesn’t find anything. It’s like my node knows about the transaction but no other nodes do? Any idea on what might cause this?

sorry, can’t help any further :frowning:

1 Like

@louneskmt @aarondewes have you ever seen this before? I’ve used other nodes / sent plenty of transactions but have never seen this issue before…

Are you sure the bitcoin receiving address you entered was correct?

Node is 100% synced. If I go to using my node, transaction shows up as unconfirmed (3 sats / vbyte sent 4 days ago). If I go to in a separate browser or any other block explorer not attached to my node, it says ‘transaction not found’ or something like that.

It’s like my node knows about the transaction but no other nodes know about it?

Yes. I can search the address using with my node and it shows a pending amount. But if I search the exact same address with another block explorer not associated with my node, it shows zero pending amounts.

I’m afraid the community can’t help you with this problem. Try contacting the Umbrel developers.

1 Like

What is the best method to do this? I’ve tried messaging here and in the Telegram group with no luck…

If it’s OK with you try pasting in the transaction id so we can check on our end.

1 Like

Transaction ID: 936e32d3ac7913df3e6c651d2ea2d84ed9706578c9f09fd14c29e44718952cd4

Screenshot from using my Umbrel:

Screenshot from without using my Umbrel:

It has been this way for about 5 days now…

Not visible in my memoool either. This means the transaction needs to be re-transmitted to the network. Here you can do that:

But, somebody else needs to help how to extract the required data from your node.

1 Like

Looks like this may work:

I’m out of town for a few days but will try to see if this works when I get back. Thanks so much for the assistance @btc_ln

1 Like

Check out this response on another post: Using bitcoin-cli on umbrel

The transaction hasn’t been broadcasted properly to the network. A reboot should solve the issue. Have you tried a reboot yet?


I just restarted the Umbrel. It’s been about 5 minutes, and still having the same issue. Transaction shows as pending for 8 days on my Umbrel, but I can’t see the transaction on a normal block explorer. How long should it take to rebroadcast?

Update: I restarted my Umbrel and updated, but still no luck. I finally got it to broadcast by doing the following:

  1. ssh into umbrel

  2. ~/umbrel/bin/lncli listchaintxns

  3. Find the raw_tx_hex for the failed transaction

  4. Copy the raw_tx_hex into

After following the above steps, I can pull up the transaction via other block explorers. Thanks for the assistance all!


Still curious if you have any ideas how this might have happened, @louneskmt. I’m kind of hesitant to send transactions using my node again