Suddenly cannot reach umbrel.local any more


Since this morning my go-to browser to acces my umbrel can’t reach umbrel.local anymore.
Also my Specter Desktop can’t sync with Bitcoin Core any more.

I have accessed my umbrel via IP adres and logged in.
Everything is fine with the node.

Before I tried to log in via umbrel.local I connected my iPhone to my desktop.
The moment I connected the iPhone I received the following message:
‘A software update is required to connect to iPhone.’
Pressing ‘allow’ got me to this page.

I installed the update.

I don’t know if it’s related to my connection issue.

So, what do I have to do enabling acces via umbrel.local again?

Desktop: macOS Catalina 10.15.5
Raspberry: Raspberry Pi4 8GB Ram
Umbrel version 0.5.3

Thank you in advance!

To Be honest, I just added the IP address to my hosts file on my computer and it works better IMO… Sometimes the umbel.local does not register on my network automatically for some reason and adding it to my hosts file seems to work better.

This might fix the issue with Specter Desktop as well…

Here is a quick google search result on how to add it on macos…

Hello @Synicasm,

Thank you for your reply.

I’ve followed these instructions from @DarthCoin:

My browser can now connect via umbrel.local again.

Still Specter Desktop can’t connect to node.
I’ve uninstalled Specter Desktop on my desktop and installed Specter Desktop on my Umbrel.

So, for now, my issues are solved.