Raspberry Pi & Umbrel work, but no command line, need to swap drives

I must confess that I may be a bit over my head here, or perhaps these are just stupid questions / problems, and I don’t know how to bootstrap my knowledge to the minimum needed to get through them.

Background: I went through the RPi build following the instructions here: new 8GB RPi 4 with aux fan, 500GB SSD connected via USB 3.0 jack on RPi, direct ethernet cable to router, new functional monitor connected via HDMI cable, Mac keyboard connected via USB cable (not using bluetooth), wired mouse connected via USB cable. The install of the Umbrel software to a brand new Lexar 32GB microSD card went fine. I have been able to connect via various Macs on the same wifi at umbrel.local – still able to connect 4 days later, even after installing an Umbrel software update. I have successfully downloaded the entire bitcoin blockchain, and everything seems to be working fine as far as the node itself.

Problem 1: I can’t seem to get the keyboard / mouse / monitor connected to the RPi to give me a command prompt or otherwise respond to my inputs. The keyboard is known good (and is connected via cable), the monitor has a good connection (indeed, it shows all sorts of information about completed actions, as well as a QR code for remote access, the Tor address to the RPi / Umbrel node, etc.), and the mouse is brand new (but the display is showing ASCII not a GUI, so not sure that the mouse would be active).

I can connect using Terminal from one of my Macs, but isn’t the point of connecting a keyboard and monitor to the RPi that you should be able to enter Linux (or other) commands directly on the RPi itself? Or am I missing something?

Problem 2: The 500GB SSD, which was the only free drive I had when I started, is now almost full (466 / 492). I have a newly-arrived 1TB SSD, and I’d like to transfer over everything from the 500GB to the 1TB. I understand that the RPi doesn’t have enough power to run both drives simultaneously (and I don’t know how to copy or move files from one drive to another via sudo/command line…and I don’t have a command line on the RPi itself). I think I need to disconnect the 500, plug them both into one of my Macs, and then…what, exactly? Will the Mac be able to duplicate the contents of the 500 onto the 1TB? Does the Umbrel / RPi use some kind of partition scheme that is different from Mac OSX native? Is there some quick way to do this?

Problem 3: I’ve read in a few places that powering the RPi off and on can corrupt the software on the microSD card. Is this true? Should I be worried? What about moving the Umbrel software onto the 1TB SSD and using that as the boot device? Will the RPi run without an SD card in the slot?

Problem 4: Really dumb question: can our Umbrel-driven RPi’s run a GUI-based operating system “overlay” of some sort? Or, does everything need to be done via the command line (if I ever get one on the RPi itself)? Isn’t the Umbrel software a customized “build of Linux”?

Thanks in advance for any help anyone can provide.

1 Like

I believe I have a similar question… Is there a way to setup a second full node on an additional Raspberry Pi with a new SSD, using a copy of the blockchain from the already synched node? (To eliminate the days required to re-synch a new node from scratch)

(I have Umbrel running on RPI 4 with 1TB SSD that is 100% synched with the blockchain and has one active lightning channel.)

Very impressed with the ease of setting it all up! Thank you!

1 Like

For problem 1:
You can get command line by SSH, as the tty1 you see on the HDMI output will not take any inputs.
You do this by ssh umbrel@umbrel.local or ssh umbrel@<ip_address> if the umbrel.local does not work (for example in my network it is umbrel@ The keyboard/mouse input is disabled for security reasons on tty1. The password should be the one you set up with the dashboard, or if you haven’t set it up yet, the default password is moneyprintergobrrr

For problem 2:
For the cloning from 500GB to a 1TB SSD, I’m not entirely sure about Macs, but I tried googling it… and it is for the computer itself, hopefully you can figure it out somehow. I have instructions for Windows, but it wouldn’t be any help since you got a Mac, but here it is: [GUIDE] Cloning or Migrating SSD/HDD (Windows)

Problem 3:
While it is true that powering off the RPi can cause the SD card to get corrupted, but that should be ok, but you should be able to reflash the SD card, and then it’ll take the data off the SSD as it stores pretty much 90% of the Umbrel software (Umbrel devs, correct me if I’m wrong) – and the remaining 10% is to let the RPi be able to boot. I know we can just update the bootloader to the latest version and then enable USB booting and doing away with the microSD card… but it is for redundancy i my opinion.

Problem 4:
Umbrel is mostly web-driven UI, but yes you can access the underlying command line interface, see the answer to problem #1 for the access. Edit: The underlying operating system is identical to the Raspberry Pi OS Lite (the version without the desktop), and the way you explained it makes sense, the node is a server.


You can copy the ~/umbrel/bitcoin/blocks/ and ~/umbrel/bitcoin/chainstate/ to the newly created node (the directories should be the same), so it would not have to resync from scratch. Keep in mind you might want to pause the ongoing sync on both nodes ( sudo ~/umbrel/scripts/stop ) before copying anything… then when you’re finished, you can restart Umbrel by sudo ~/umbrel/scripts/start on the one you already have fully synced, but not the new node: you want to reboot it by sudo reboot
That should kickstart it and you’d be syncing the last few hundred of blocks and you’d have 2 fully operational nodes. Good luck!

Thanks - some very helpful information in here. Let me unpack:

Problem 1: Sorry, but what is “tty1”? I don’t follow what you’ve written.

That’s interesting (crazy?) that you can ssh into a remote RPi with what seems to be almost no effective security (a default password that everyone can find), but if you physically connect a keyboard and mouse to the actual RPi via USB that’s right in front of you, the default is that such physical access is disabled. Seems a bit backwards.

By the way, I set up a username and password combination as part of the getumbrel setup, but isn’t this a ridiculous security risk? Aren’t there malicious actors probing internet-connected RPi’s 24/7 with default username-password combinations, trying to gain remote access, install malicious software, whatever?

How can I re-set the security parameters in the RPi to permit access / control by direct USB connected input devices?

Having done that, how would I then block ssh access going forward?

Problem 2: I went part-way down the rabbit hole, looking to run a Linux virtual machine on my Mac to enable use of the dd command to move files between the old and new SSDs, but then thought to try Balena Etcher. It turns out Etcher has a clone function, so I’m trying that now…it’s taking about 75 minutes total to clone the 500GB SSD to the new 1TB SSD. I don’t have a Linux box to check to see if the “flash” to the new drive works, so my ultimate test will be to re-boot the RPi running Umbrel and to see if it can see the downloaded blockchain.

Problem 3: I’ve just removed, reflashed and reinstalled the microSD card with a fresh copy of Umbrel. Hopefully that works. I still would like to move the operating system from the crappy microSD implementation to the SSD.

Problem 4: I still don’t follow the non-ssh / direct operation of the RPi running Umbrel’s custom build of Linux. I might want to be able to use the Umbrel / RPi combination for other things while running it as a Lightning / Bitcoin node…maybe that’s just not possible, and I should buy another RPi for that, run NOOBS and go from there.

Update (problem 2): probably not a surprise to those with more than a few functioning brain cells (read: everyone other than me), but “cloning” a mostly-full 500GB drive onto a 1TB blank drive gives you…a mostly-full 500GB drive sitting on a 1TB capacity drive. Because I “cloned” rather than copied folders and files over to the new drive, my new drive is now only using 500GB of it’s capability. And I’m still out of space.

So, I still need simple instructions on how to format my 1TB drive and then to copy over the files from my existing 500GB drive to the new 1TB drive. I only have access to Macs.

@DHD Many thanks. I’ll give that a try - sounds very straightforward.

So, solved my own problem. Created a NOOBS-type installation on a second microSD with Ubuntu (non-Umbrel) on it, powered up the RPi with that microSD, and was able to see what was going on with the two SSDs.

After some research I ended up downloading GParted, which allowed me to use the “Check” function under the “Partition” menu to repair the 500GB clone ‘image’ sitting on the 1TB SSD. It extended the clone to take up the full 1TB as usable space. Powered down, swapped the Umbrel microSD back in, disconnected the 500GB drive, powered up, and now I’ve got a functioning 1TB drive with the whole blockchain on there. (The 500GB SSD has ~98% of the blockchain on it still.)

The Umbrel is now updating nicely and running fine.