Umbrel not recognizing SSD

I’m trying to get Umbrel set up and it keeps hanging up on the external drive with the message of:

Error: No external drive found

Please connect an external drive (at least 1TB) to a USB 3.0 port (blue color) on your Raspberry Pi and restart your Umbrel.

I purchased a brand new SanDisk Extreme 1b SSD (up to 1050 mb/s read, 1000 mb/s write). I plugged it into the blue usb port and again, nothing.

Any thoughts on a fix before I return the drive and give up on this project? I’m running a RPi 4 as well.


1 Like

I had a similar issue using an older WD disk I had. Just reflashed the sdcard Umbrel image and installed in less than 5 mins. Awesome piece of work, don’t give up. It’s really impressive !

Tried twice. Doesn’t fix it. This is a brand new ssd bought specifically for this and never used anywhere else.

If it matters, the SSD is powered off the cable that’s plugged into the Raspberry Pi. The Pi is powered off the USB-C cable plugged into the wall. Could there be an issue with power?

Im having the same issue. I think the Pi is bad? Ive switched ssd cases and cords. Same issue. It will run for 3 to 20 min, then my sync crashes to zero percent. Very frustrating

I was having a similar issue with umbrel booting and then crashing after a few minutes. Reflashing didn’t help, but what fixed it was using a different case for the SSD. I have an external ssd dock that is USB and put the SSD drive in that. It is externally powered rather than powered over usb on Pi. That fixed it and umbrel has been running fine since. I have one of the recommended ssd case from the umbrel site coming soon. Hoping that fixes the issue. When I built the node a few months back - I bought all of the parts from the website, but the SSD enclosure was not available, so I got what I thought was similar enough. I suspect different enclosures have different power draws which was causing the SSD mount to fail. The issue for me only happened after upgrading to Umbrel 0.4.0. My set up ran fine for 3 months before this past week I had issues.

Try a different enclosure or one that has its own power.

I had the same issue with the recommended case being out of stock. I just received the correct one today and things are still acting up.

I am toying with the idea of switching to an externally powered SSD, but I don’t have a lot of spare change to be replacing ssds.

I’ve been running good now for 17 min. Almost at 70%synced now on day 6…lol

My system kept crashing. I kept restarting. It was not fun. I replaced the SSD case with this cable:
SATA to USB Cable, Benfei USB 3.0 to SATA III Hard Driver Adapter Compatible for 2.5 inch HDD and SSD. So now the Pi connects directly to drive. No cash on hard drive.
And it’s working like a dream! Can’t thank you guys enough. Great job!! That cable is $10 on Amazon. Came next day and bingo!

I have the same Sandisk SSD and it worked. i would try not putting anything into your USB plug other than the SSD USB. and use the normal power plug

I have a 3.0 to sata cable on order from crucial. I hope that will do the trick. I will follow up

This finally worked. I have no idea what was different or the cause of the issues. It hung on starting up overnight and when I woke it was synching.

I wish I had a better solution to share…

Also, formatting the SSD to the correct format (Ext4) is SUPER IMPORTANT but a step which I feel is missing from the installation instructions. I followed the User Guide step by step but completely missed formatting, thinking that it would be included in the boot sequence.

To help total noobs I think it would be useful to mention the formatting required for the SSD/HDD before booting Umbrel.

I changed an enclosure to a cable, reformatted my SSD and rebooted Umbrel and we’re syncing (55% in 4 days)…

Looking now at the quickest and least power-sapping SDDs. In hindsight, I should have maybe gone for an NVMI M2 style SSD with an extension board - wish I had know this was an option before buying my Crucial MX500.

Yes, correct format of SSD is ext4.
But that is done also when you install first time Umbrel.
So if the drive is brand new (no partitions) it will be formatted in ext4 in the process.
Formatting it in ext4 from the beggining it doesn’t hurt, but users should keep in mind: do not format it in NTFS or using Windows systems. That will make unusable the disk and you will need to re-format it in ext4.
In the troubleshooting manual there’s a procedure mentioned (for when you want to copy the blockchain data from another source) about how to use ext4 disks on Windows.

y know? I still appreciate what you shared a lot. I have the same problem here. The system tells me that the SSD is okay, but the website still says: NO (Please connect an external drive (at least 1TB) to a USB 3.0 port (blue color) on your Raspberry Pi and restart your Umbrel.)

I hope tomorrow when I wake up I will has the same result like you ^^

In the beginning, I had lots of those problems with external drive, files corruption, etc, and found problems both in USB cable and USB to SATA adaptor.
If you decide to do a new clean install, before it, ask and i can show you simple tests to verify those parts.

1 Like

Same issue here with a Brand NEW BitcoinMachine :thinking: the green light on the (2TB) SSD turns ON (Green - Not Blue) but the Ui always shows the same message:

I’ve already:

  • open the box and check if the hardwares are well connected
  • rebooted the TBM few times (no change)
  • connect the SSD with different USB cable (no change + replaced the original one)

@LoboGuara please do share those tools for testing, it will be really useful :pray:

Sorry for the issue!

For @n080dy and The Bitcoin Machines users, can you please confirm if everything is connected correctly as per the instructions on this article here?

@mayank yes, confirming everything was connected, but just green light, no blue ligh… now the BTM is unmounted and I’m worries the HD or the USB connector are gone and need replacement.

I already connected the HD to a macOS and the drive is not recognised from the Utility Disk nor from terminal when running a df -hcommand

If there’s a way I can fix/reset the HD or check somehow if the USSB connector still alive will be great… Or alternatively what will be next step?

Thanks in advance

HD is not suitable to this project. Recommended use SSD.
You need a sata-to-usb3 adapter (external disc case) to test the SSD.
With it, writing files and testing write speeds to the SSD gives hints what is the bad part.

@LoboGuara sorry my mistake, for HD I actually mean the SSD that came by default with theBitcoinMachine. Today discovered that the SSD died already, so I had to buy another one.

Now, replaced the SSD and the blue light is on, but the same message still appearing. Restarted twice, same result.

What else it can be?