Node unresponsive, unreachable, but boots

My ubrel worked fine for few months. now there is some odd problem with my umbrel. when I connected an external monitor, i see that it boots up fine, debian from the sd card is waiting for umbrel login.
However, I cant ping or ssh to it, and naturally cant reach web UI.
SSD disk (crucial mx500) is blinking as if there is some activity (blue on all the time, red blinking every few seconds). I am using it all over wifi, so maybe that is the problem, but it was not a problem for last few months. Please advise where to start diagnosing and fixing it?

looks like my initial hunch was spot on, once I moved it downstairs, connected it via an ethernet cable directly to the router, it immediately got an IP, and started syncing for the days missed.
It is still unclear why the wifi was not working when it did worked before, using usual wpa supplicant approach…

2 hours later: everything is synced up, can see both total ballance and bitcoin + lightning ballances, BUT the 20+ channels I have had are now inactive, and Ligtning node appears to be somehow not well, cant send any payment with error: server is still in the process of starting…
Something funny is happening…dont know what to do next.