Bitcoin node won't startup or if it does, it stalls

Hi All, I’d really appreciate help from this community on this topic.
Bkgd - I’m not a bitcoin newbie, I’ve been running my own node for over a year now on Win10 (Thinkpad Yoga14 w/ 2Tb SSD and 8GB ram) but I’ve had lots of issues with Bitcoin Core software inexplicably corrupting itself on Windows, having to wipe it clean and re-download the whole blockchain. Lately I’ve wanted to get into lightning and I want a version of that I can use to explore MY node’s mempool specifically. Umbrel seemed like THE solution to this.

I AM a linux newbie and an umbrel newbie. Since Umbrel doesn’t run on windows (to my knowledge anyway), I wiped my Thinkpad clean, installed Linux Mint, and now am trying to ONLY use it to run Umbrel.

Here’s the Problem(s):
Umbrel installed fine and from the Umbrel App Store, I installed Bitcoin Node. When I first tried to open it, it sync’d up to block 228,625 (1.67%) and then just sat there doing nothing for more than 24 hours. So I logged out of Umbrel, rebooted the machine and tried again and it sat there on “starting” doing NOTHING for hours. So I logged out again, rebooted, deleted the whole Bitcoin folder /home/umbrel/umbrel/app-data/bitcoin/data/bitcoin and then tried to launch Bitcoin Node again. This time it got further - sync’d to block 442,387 (19.52%) but then did the same thing - just sat there doing nothing for days.

I’ve looked through the Umbrel troubleshooting steps and it talks about doing ssh into umbrel (I don’t understand what this is or what it is supposed to accomplish, but I tried it per the instructions) and my terminal gives the following “ssh: connect to host umbrel.local port 22: Connection refused”

I don’t know what the heck is going on, but this is super frustrating and time consuming. Is my ISP “throttling” this somehow? I don’t even know how to check if this is the case. A lot of the tech solution steps referred to in the comments assume basic knowledge of Linux and interfacing with the terminal/running commands that I simply don’t understand.

Really appreciate y’all’s patience and help here!!