Node Syncing stalled

My raspi node 4 gb with hdd hard drive has been slowing syncing for 4 months, since I first set it up. It got slower and slower till now its basically stalled at 96% for weeks. Connected directly to my router- I live in an urban area with otherwise good internet. Apps having similar problems- when I open them they are no longer connecting very quickly if they work at all. No peers anymore. This happened as a gradual slowing down until everything just seems stalled. Yes I’m updated to lastest version of umbrelwith urbit.


It’s not recommended to use HDD for Umbrel, as the syncing will get slower as the blockchain grows – so you might need to get a SSD. If you would like to keep the HDD – what is the size? If it’s under 1TB then that’s why.

In fact it is mandatory to use a SSD. In Umbrel the system is in the disk, program and data needs to be loaded from disk all time to the RaspPi process them.
The transfer speed of data are very different:
From a HD with a usb2 sata adaper - 12MB/s
From a HD with a usb3 sata adaper - 30MB/s
From a SSD with a usb3 sata adapter - 160MB/s or greater.
And even with the SSD, sometimes system gets slow…

I replied to somebody else here, with a similar issue.

I run also an Umbrel with HDD, not SSD, but in a NUC with Debian OS. I have no issue with “slowliness” as many here try to say.
Yes, SSD is faster than HDD, but that is not affected too much when you restart your node and is catching up.
Umbrel is recommending SSD for RaspPi users, so when you conect that external HDD drive through USB and a case, is a like a bottleneck. HDDs are NOT designed to be fast as external drives. Things are changed when you use them as internal drives, in NUCs or PCs not RPis.

Yes, they are right: if you use a RPi use a SSD and a faster SSD that can get.

The main issue with taking long time to catch up blocks after restart you can see it yourself by looking into bitcoin logs, through SSH:

cd umbrel
docker-compose logs bitcoin

Then you will see that it stay long time to find a good peer to catch the blocks. It has NOTHING to do with your internet speed, disk speed, machine speed. It just wait for a good peer.
As you can read in that guide about running in hybrid mode there are more chances to catch good peers faster.
Once the peers are found you will see in logs that the sync go smooth, no need to panic that your node is having any issues.


Would you recommend that I buy a SSD and start over then?


1 Like

So I have updated the hard drive- the procedure I used was flashing a copy of the old drive ont othe new SSD- and reconnecting. It seems to see everything fine, files ,etc, but the bitcoin core is just sync’ing now and never connecting to chain at all- this was actually a problem before - now however it seems to not connect at all ( been in this state 24 hrs). SSd does make the pi go faster though!

I guess it is better begin a flesh install, as files could be corrupted by memory overflows.
Before that, look the cpu activity, use command TOP. Maybe CPU is busy indexing database.

I’m increasingly thinking it is some type of connection issues- I woke up to another 10 gb downloded today. So it must have connected some time in the last 24 hours.

Any advice on what could be slowing down connection? Somethign with my router maybe?

4 months sync is excessive I think! @Event_Horizon you really have a lot of patience!

I’ve posted my solution for sync stalled here… the easier path sometimes works first!

How many peers you have in bitcoin page? For me it varies from 10 to 12, and my sync time was less than 3 days with those peers.

Another thing that I noticed is that sometimes, either for a few seconds or minutes, the sync animation (the cubes for each block) get stuck and storm rolling, I believe that is just an Ui issue and the sync still happening in the background.

Thre’s a way @here to check the sync progress live via Terminal/SSH?

At various times I’ve had 2 or 3, on and off… but now it just syncs continuously.

Ah the good old unplug it technique - just did it, and now my new ssd is showing the same amount of blockchain downloads it started with… so perhaps the additional download over the last few days was a mirage?

Anyway-- clearly I have some how not started this off correctly. At the place where it feels like it might be easier to re-flash this thing and start over. Anyone giving me advice- please send long tutorials because I’m very noob and not super familiar with how to even get to command line on these systems… clearly that may need to be a thing though. Trying to set this up after alot of long shifts… See Longs if this helps anyone. umbrel-1645157490423-debug.log (63.1 KB)

Debug look’s good to me… to check progress from the terminal. My solution was log-in/log-out. That apparently did the job (maybe clearing the browser cache) and updated the sync’ percentage. @Event_Horizon just be patient and wait for the 100% maybe with some popcorns :popcorn:

I feel something is def wrong though because it isn’t progressing. I’ve been trying the waiting game for 4 months so… lol.

Then start over.

4 days is normal, not 4 months.
From my experience and from dozen complaints i see here, those not sync problem is caused by hardware problems, people using not recommended parts, or if those parts are broken.
You should test the external storage system performance, it is main issues cause of this sync problem.
That is simple, just write a large file to the SSD, then do a copy of writen file to the same SSD. Auto-copy speed can not be less than 100MB/s, if less something is broken. A good storage system should get a copy speed of 100 -160MB/s.


I started with an HDD because that’s what I had laying around, then bought a 1 TB SSD drive. I used BalenaEtcher to transfer data from the HDD to the SSD (I was already about 60% synced). Worked great. Saved having to start from zero with the blockchain.

you mean cloning it? On windows?