Node stuck at "Synchronizing 0,00%"

Hello, I’m a noob at setting up a node, but been trying my best after watching many tutorials and doing my due diligence.

I’m running Umbrel on:

  • Raspberry Pi 4B 4GB RAM
  • Micro SD Kingston 32GB
  • SSD Samsung 870 QVO 1TB / SATA III
    The RBP is connected to the router via ethernet cable.
    The problem I have is that after energizing the RBP, I access the Umbrel dashboard from my computer (either via ethernet or wifi), everything looks fine, except that the blockchain synchronizing just won’t start. I’ve read in this forum many cases where it gets interrupted. In this case it says “synchronizing 0,00%”, there’s a bar moving from side to side as it would be working, but it just remains there at 0,00%.
    So far I’ve tried flashing Umbrel on the SD card a couple of times, formated the SSD several times with different formats, but it’s all the same.
    Any idea what could be happening or what am I missing here?
    Thanks so much in advance.

If you can access the dashboard, go to settings and generate the debug log.
Or follow these instructions

Without logs to see what happen, we can’t help you diagnose.
But as far I saw, cases like these are because of hardware failure of your SSD: case, cable, drive or the power adapter that is not giving enough power.
So start there investigating.

Thanks DarthCoin! I wasn’t making sense on how people were sharing the debug file through a link.

Here is mine:

There’s one more thing that I’ve been wondering about. Is the case for the SSD drive indispensable for it to work? Here’s the thing, I disregarded the case thinking that it was just an extra protection layer for the drive and to make it look nicer. Instead of the case I bought a SATA-USBC cable, so my RBP is connected straight to the SSD drive (without case).

I see some tor errors in there. Seems that you changed something in your internal clock of the machine?
Or you have really bad connection through tor.

I’m not aware of having changed anything though, I literally opened the sealed box of the RBP and went through the steps to install the node described on the Umbrel website.
If the problem is related to a bad connection through tor as you suggested, how can I troubleshoot that? Can you point me to any resources please?
Thanks again!

Try restarting your router, try to sync your node in another network.
I saw many shit happening with Tor in many locations.
You could activate to a hybrid mode your node if you cannot fix this Tor issue. Here is a guide. That will make your node to communicate and sync on both Tor and clearnet. Is NOT accessible on clearnet, it only sync.

Also I am strongly recommending to use a static IP for your node. Here is a guide.

There are shown several error in Tor logs.
Please test if you have a right date and time in your RaspPi.
SSH in and type command “date”. It should show correct UTC time.
If wrong, think you should correct your network time.


That was it, the date was completely off.
It took me a while to figure how to set it correctly, but finally I managed and now my node is synchronizing!!
Many thanks LoboGuara & DarthCoin for your help!! What an awesome community!!


I am really glad that you figured out how to do it yourself. This is a great achievement.


Hi, I am new and I have a similar issue. I am trying to synchronize my node for the first time but it is stucked at about 10%.

RPi 4Gb,
Micro SD sandisk 32Gb,
SSD Crucial X8 1Tb,
connection via ethernet cable.

I set the static IP following your guide and modified the network date and time that was wrong but without resolving the issue. Moreover, I can’t reach the umbrel dashboard via the tor link from the browser. ERR_SOCKS_CONNECTION_FAILED.

I attempted to re-flash the OS, reboot the system several time and formatted the SSD (before formatting it was arrived roughly to 20% of synchronization).

The debug log is at the following link. Please help me to fix it.

Something is wrong with your RPi, it shows 2GB RAM not 4GB
With only 2GB ram I don’t think you willbe able to run a node. Even 4GB is at limit for that tiny machine.

Thanks. I gonna change it and try again.

Hello again guys,
There was an electricity shut-down at home that lasted a few hours and when it went live again Bitcoin Core synchronization got stuck again. As per my previous experience this should be due to the RBP’s internal clock that is misconfigured.
My problem now is that when I try to SSH from my PC connected to the same network it just won’t recognize the password (default: raspberry) which worked fine last time and I’m positive sure I haven’t change.
How can I fix the date/time of my RBP or reset the password to access it? Why is this date/time configuration an issue on my RBP when, as far as I know, people just install Umbrel and they have them working fine right away?
Thanks so much for your help!