Node stuck on loading screen

Hello all,

I recently set up and installed my node. It was all pretty straight forward except for logging in.

I have the PI plugged in with a cat 8 cable into a switch. I am able to access it with umbrel.local and with the IP address. I’ve also been able to access it with a Mac, PC and iphone.

The problem is that I cant get further than the “welcome to umbrel” "Your journey to become bitcoin starts now " screen. The green LOADING icon pulses and it looks like its loading, but it hasn’t gone anywhere in over 30 minutes.

Ive reflashed the card…and deleted/formatted the card and SSD prior to have a clean install.

I read the other post that is very similar to my issue but the pointers didn’t help. Any other thoughts?


Same exact issue, reformatted and tried several times to no avail, seeking assistance


Same issue, did you manage to get a fix?

I am also having this issue. any progress?

1 Like

quick update for everyone. I had seen on a my node forum that a similar issue was caused by the SSD connection. For me, I just didn’t have the SSD fully inserted into the adapter… smh…

1 Like

Same issue. Cleared the micro device and started over with a new download, from windows and Linux - I wouldn’t know how to clear the ssd - but I’m at my wits end anyway- if anybody has a tip ty in advance!

For Windows: You can plug in the SSD, and right click on it in My Computer then choose Format… and when the Format window comes up, make sure it is selected as NTFS for the filesystem and the Quick format option is selected. Proceed with the format. It should be done within a minute or so, then you can plug it back in the RPi. Umbrel will detect an empty drive and take it from there.

Thanks, after a little sleep and with that good consul I’m ready to go. Thx again!

1 Like

same issue here.

Was previously stuck with both lightning and bitcoin stuck synchronizing. Reset user data, and reset umbrel, and now stuck on loading screen. 0.4.4

Hey Iowa,
Was wondering if you ended up getting past the loading screen?

I have the same issue

Same issue here, I see there is synchronisation progress through ssh. I plan for waiting for it to end before rebooting. Has waiting the end of synchronisation and then rebooting worked for anyone here?

I just found how to solve my problem! Through the guide here : Umbrel Troubleshooting Guide
And in the section: Login screen it just freeze, can’t login
And I haven’t lost any sync progress, now I’m in the dashboard!!

Hey greenpanda.

In SSH could you explain to me live a five year old how to input this (no coding experience)?
Thanks so much

Using Putty, you write the ip of your node then:
login: umbrel
password: moneygobrrr (you wont see it)

cd umbrel

then copy(ctrl+c), and paste (right click) in the console:

sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/lnd/!(lnd.conf) && sudo rm -f ~/umbrel/db/user.json && sudo rm -f ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup

sudo reboot

that’s what solved it for me… let me know how you do

By the way, with this command you are going to loose your seed, user settings, data and installed applications, similar to a factory reset, so it’s good to do only if you’re node is brand new or you have your seeds and channels backups.

Thanks a lot :slight_smile:

It worked. You are like a brother to me.


All credits goes to DarthCoin in this guide:

Also the guide section here is amazing to learn about everything. (Select ALL-TIME instead of MONTHS)

See you on the network soon!

1 Like

Good point about select ALL TIME. That option confuse many here and they do not see all the guides.
@louneskmt maybe you can set that section for guides to show always all ? I know is about each user how they setup in their account preferences, but some are new here and don’t know how to use efficiently this forum.

1 Like

You’ve read my thought @DarthCoin!! I easily imagine newbies coming often in panic (like me) and skip over the page details as soon as they see emptiness. Changing the default to ALL TIME would help everyone greatly.