Bitcoin node is stuck "starting..."

Hello, after my Bitcoin node was almost finished syncing the blockchain, it became stuck and it wont start.

Things i have already done:

  • starting the debug script (Result: “The debug script did not automatically detect any issues with your Umbrel.”)
  • removing settings.json and peers.dat by using:
    sudo rm ./umbrel/app-data/bitcoin/data/bitcoin/settings.json
    sudo rm ./umbrel/app-data/bitcoin/data/bitcoin/peers.dat

Unfortunately it is still stuck. Do you have any ideas?


Does nobody have any idea? It is still stuck starting :smile:

It is now stuck on the home screen. I am know kinda fed up with umbrel. Do you know any alternatives? Citadel? Raspiblitz?

1 Like

How much storage capacity and RAM do you have available?

I am running umbrel in a Proxmox VM:

  • 4 CPU Cores
  • 6GB RAM
  • 640GB SSD
  • Ubuntu 22.04 LTS

Could it be that there is too little SSD storage? But there are still around 30GB unused.

Yes, I think storage capacity and memory might be the issue. I run a ligtning node with only the basic apps, and I am currently using 658.4 GB of storage. I have 8GB RAM and could definitely use more.

I could bumb it up to 7,5 GB RAM and 800GB of SSD. Maybe that will work.

Maybe it would work for a while, but the blockchain is growing. 1TB is recommended on Umbrel’s page when installing on a RasPi, and I guess that would apply for other setups as well. For my next node I want 2TB SSD and 16GB RAM :smiley:

1 Like

Having same problem…

1 Like

Same issue. Last week all was working great… Did you solve it?

Canot believe this is a resource issue…

Nope. Unfortunately I killed the whole system by trying to repartition the SSD. I am just a beginner in Linux :sweat_smile: But I also don’t think that it is a resource problem either. I think have set it up again with 7GB RAM and 900GB SSD which should be enough I think.

Hmm shit :sweat_smile:

Ok, I will probably dig deeper in the coming days, will update here if I find smt

Electrs says waiting for node to finish sync, strange… It should be synced.

Need to login via ssh and read some logs probably

1 Like

Fixed it:

  1. login ssh

  2. docker ps

  3. search for ID of image “getumbrel/bitcoind:v24.0.1”

  4. docker logs $ID

This showed me smt regarding a corrupted file peers.dat…

To fix it, I did this two commands:

$ mv /mnt/data/umbrel/app-data/bitcoin/data/bitcoin/peers.dat /mnt/data/umbrel/app-data/bitcoin/data/bitcoin/peers.dat.backup


$ mv /home/umbrel/umbrel/app-data/bitcoin/data/bitcoin/peers.dat /home/umbrel/umbrel/app-data/bitcoin/data/bitcoin/peers.dat.backup

Then restarted umbrel via UI.


Perfectly fixed with your instructions, thank you 0x188181818


I have similar issue now after my upgrade of Lightning node to v0.16.2-beta.
Can I just need copy of your 2 commands after ssh into my umbrel or should I need to customize anything?

Thank you.