Initial startup, stuck on "Loading" screen

I am new to this. Forgive me. I just built an Umbrel and when I plugged everything in I went to umbrel.local on my computer and can’t get beyond the screen that says, “Welcome to Umbrel. Your journey to become bitcoin starts now. Loading.” Can anyone help me?

figured out how to debug

Still stuck on the Loading screen. Tried re-flashing the micro SD card and restarting. Same issue. Can anyone help with this issue?

Is barely started to sync man. You have long time top go

Give it a bit more time. If is still not let you to login, means that something is wrong with your external drive / usb cable / case / power source. These are always failing.
So be sure you are using the original ones or the good ones.

Thank you. I guess I was confused. I thought before and while it was syncing I would create name, password, etc. So I can’t get to the dashboard before it syncs?

No, it should let you create the user /password and save the seed. Only that the rest of the node is not yet functional, but dashboard should come up.
So something is wrong with your setup.

Thank you. I unplugged everything, erased everything, and started over. It worked. Syncing now. Thank you!