Node stuck in "syncing"

The system crashed again after shutting down and rebooting, I had to wipe the SD card and got it back up but it’s not connecting to the database by the look of it. I have had this before and fixed it but can’t for the life of me remember how!


Running into the same issue, re-flashed SD card and still no resolution…

Its the flashing of the card that causes it… then its like the new install cant access the blockchain data on the HDD so it just sits there, like I say I’ve fixed this once before but cant find where!!!

I am having the same issue. Rebooted multiple times and re-flashed the SD card. Still no go. Logs note a few issues: Attaching to bitcoin
bitcoin | Error: Failed loading settings file:
bitcoin | - Unable to parse settings file /data/.bitcoin/settings.json

I got mine working by removing the settings.json files located here:


That proper broke mine now…i think its time to find another use for my Pi4… Umbrel looks nice but its kinda broken at this point

1 Like

Thanks for the solution
I’m having the same problem. Is there a guide on how to remove the "setting.json
I’m able to SSH but lost on how to navigate my way to the proper directory to remove the files.

Any assistance greatly appreciated.

Look up how to use the linux terminal. cd and cd … are basically how to get around. ls -all will show you the files.