No BTC address to deposit


I’m trying to add BTC to my node wallet but there’s no option, it seems to just be greyed out and no address comes up.

I took 0.1 off the other day as it stated I had 23 million sats and had enough to cover my lightning node @ 13M. Now there’s just 3M sats on my lightning node, all channels are inactive (yellow) and my BTC wallet isn’t showing anything.

Any help? Thanks

We need to see logs from your node, something is not starting up correctly.
SSH into your node
cd umbrel
docker-compose logs bitcoin
docker-compose logs lnd
docker-compose logs electrs

Or simply go to settings and run the debug logs, copy the entire log and paste it into and share the link here.

I tried docker a while ago when looking at setting up a ETH node but failed lol so this will have to do I guess.

I use Umbrel because of how easy it was to set up and wanted to help run a full node and contribute to lightning. Unfortunately that’s about where it ends.

Hope to get to the bottom of this and get the lightning node back up and running.

I did try to send 0.01 BTC to the node as an address finally came up. It left the wallet and the tx was completed but still doesn’t show up in the node wallet?

Thanks :slight_smile:

I saw an error of not opening the lnd wallet but then in the end was open
[ERR] RPCS: [/lnrpc.Lightning/ListChannels]: wallet locked, unlock it to enable full RPC acces

Are you sure you didn’t edit anything in your lnd.conf file?
Try to reflash your mSD card with the latest version of Umbrel, same operation as when you install it. Just shut down normally the node, unplug the mSD card, flash it, then put it back and start the node.

Let’s see from there. There’ no worry to reflash, only OS is on it, all the rest of user data in on SSD. Sometimes these mSD are shit and broke easily. A reflash could fix quickly.

Only thing I did was send out some BTC and then yesterday I did the latest update.

I’ll give it a bash and let you know, thanks :slight_smile:

hm so no fix, not good. Not sure if still the same problem?

I formatted the card and re-flashed, turned it back on and seems to be OK but no wallet address pop up and the 0.01 test BTC seems to be lost even though it did provide an address at one stage.

No, is not lost, only that you still can’t access it. You can easily import the seed into Bluewallet and see them there, in onchain wallet.
For the LN channels, you could make a backup of them (see my manual) and later could be restored the funds back into onchain.

You post the hardware logs. Post the other tab with software.

Try this
Enter using SSH into your Umbrel node and run:

sudo rm ~/umbrel/bitcoin/settings.json

Restart the node machine

sudo reboot

are the comments hidden for some reason? Says they’re hidden by community flags

Hi, downloaded bluewallet and all good, BTC got there. Flashed the card again today and no luck.

Have a friend that’s better at this stuff and he helped me with what you said about using SSH and did what you said but no change.

Think these are the logs you where asking for

I’m under the assumption that the copy of the blockchain on the 1TB SSD wouldn’t have anything to do with this issue as it’s just a copy of the BTC chain?

So flashing the micro SD should have done it no?

Maybe something on the computer? Not letting it see it? Would it matter which browser you use?

Sorry this is really strange as I never had an issue in about 8 months till I did one withdraw. I was sending mining fees to it and opening lightning channels. From what I could see there was over 0.23 BTC in there which 0.13 was allocated to the lightning nodes and over 0.1 was in the BTC core wallet. Transferred out the 0.1 and now it’s sitting at 0.03 BTC

I tried to share the logs but just says it’s spam

Don’t know, maybe some other eader flagged your comment. I didn’t. I don’t know what they didn’t like it to that comment. Who knows, maybe was by mistake.

So you are sending to your node a lot of BTC from other sources?
Man, a node is NOT a storing vault or HODL wallet!
a LN node is a LIQUIDITY machine. That means you put in it only the amount you are using as liquidity, to flow, to be spend, to be used in channels etc.

I wrote this guide especially so user can learn how to deal with their stash securely, using the 3 levels of stash.
A node is just a “cache level” not a HODL level.

re-flashing the mSD card it doesn’t do any harm but good to your node. All user data is on the SSD not on the card. So if you thin that the card was hit, reflash it.

To post logs here use - post only the link where you paste your logs.

no wasn’t sending there for storage, was sending there to set up lightning channels. Just happened to have more then was on lightning at the time.

Annoying thing is the history on the BTC side of the node seems to be missing now so I need to investigate and see what happened and how much was there.

So user data is on the 1TB SSD? So I’d need to wipe it and re-download the chain?

Why?! No, don’t do that, only if your drive is not accessible at all. That is the last resort. Also you need to make backup of your channels.
Please I wrote a lot of guides and documentation in this matter, read before doing any crzy thing and lose all.