BTC/Lightning Addresses BLANK?

Hey all,

I am running an Umbrel Node on the Raspberry Pi setup with all the recommended hardware.
The blockchain completed downloading/synchronizing on 7/2/2021 (3 days ago).

Once the blockchain finished downloading, I updated Umbrel to the latest version, using the link in the dashboard.

However, I cannot deposit BTC into my BTC Wallet or the Lightning Wallet.
When I click the Bitcoin Tab, or the Lightning Tab, and then select DEPOSIT
I get a BLANK address field, and an invalid QR Code.

I have searched this community, as well as asked for help on the Umbrel Telegram group. I restarted my Umbrel multiple times, and then left it off/unplugged for 24-hours.

I plugged the Umbrel back in this morning, let the blockchain catch-up, and still BLANK ADDRESS FIELDS. I restarted the Umbrel AGAIN, and still no luck…



1 Like

Hi, I’m having the same issue.
Opened the dev console and I see 403 (Forbidden) error when the dashboard is making api calls such as http://umbrel.local/api/v1/lnd/wallet/btc, http://umbrel.local/api/v1/lnd/address. I see the message “Must unlock wallet” along with the 403 error.
Using Umbrel version 0.3.13 and 0.3.14.

I have re-flashed my SD card and installed the latest version 0.3.14. The problem still exists.
For more info, I was able to deposit BTC once, just after finishing the blockchain sync. Then after a day or two I was trying to make a second deposit but could not because I couldn’t see my btc deposit address.
Currently the dashboard shows my BTC balance from the first deposit correctly, but it keeps showing blank deposit address. API error says “Must unlock wallet”. Is there anything I should do to unlock my wallet?

Anyone know how to generate the bitcoin wallet from the command line?
As well as generate the lightning wallet, from the command line?
I think that might help, as neither of my wallets were ever functional.

If you can ssh login to the Umbrel, run

~/umbrel/bin/lncli --help

if it works, then maybe you can try

~/umbrel/bin/lncli newaddress

TBH I am not sure what the consequence will be though.
I haven’t tried it because I have some balance already.

1 Like

Looking into lnd’s log file, I found that the lnd service was restarting every 1 minute. The lnd wallet was actually being unlocked for about 2 or 3 seconds, then locked again for about 57 seconds until next restart. This cycle was repeating forever.

After some experiments, I also found that the cause of this ‘lnd restart loop’ was that there was a Tor connection problem.

ls -alt ~/umbrel/lnd

If you see a file named ‘v3_onion_private_key’ with a size of 0 bytes, then you need to delete it.
In my case, it started to work fine after deleting the file.

Just as a reference, here is a part of my lnd log.


Hey all - got a solution!

Keep in mind, I had ZERO Sats in my wallets, so it wasn’t an issue to restart and get a whole new seed phrase.

I was instructed to use this command:

`sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/lnd/!(lnd.conf) && sudo rm ~/umbrel/db/user.json && sudo rm ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup`

However, it returned an error because the seed file 'could not be found.'
I ran the last command in the string:

`sudo systemctl start umbrel-startup`

And Voila! My node is now fully functional!

Good luck - and remember, you will lose any sats on your wallet(s) using this method!


where exactly you find that v3_onion_private_key, in lnd folder ?
I have that file and my node works just fine with it.
Or you mean that if is empty, it should be deleted and will be created again at node start?

1 Like

@mayank or @lukechilds what do you think about this case?
Is it caused by low swap memory or disk corrupted data?
What should do in case the user have funds in onchain wallet?
Is there a way to make it running again without reset user data?

Hi @DarthCoin, yes, I found the file in the ~/umbrel/lnd/ folder. The file was empty (0 bytes).
After I delete it, it was recreated automatically with 99 bytes of text data in it. Then everything started to work fine again, including my previous sats balance.

A part of my lnd log file during the problem was happening can be viewed in here:

I have no idea why my v3_onion_private_key was empty. The problem just started after about 2 days after the IBD. All I did before that was to deposit some btc.

FYI, I can reproduce the problem by deleting v3_onion_private_key and creating it as an empty file with touch command.

1 Like

I asked because exactly the same scenario was happen to a friend of mine.
Setup Umbrel, all ok, synced 100%, wait for electrs to catch up, all ok.
Then just deposit some 2M sats onchain and boom, not even can read the LN node id.
Then I saw that Tor log seems to be stopped and also lnd service it just shuts down itself.

Will try your solution and will come back.
Thanks for sharing.

1 Like

I was troubleshooting and somehow arriving here. My V3_onion_private_key is has a size of 99.

For the record: with what command would I be able to delete the specific file?

Hi, I’m not expert but if the file is not empty, probably you have a different problem so deleting it wouldn’t help. I would recommend to check your lnd’s log file with a command like:

tail -f ~/umbrel/lnd/logs/bitcoin/mainnet/lnd.log

In case you would like to try though, this is the command to delete the v3_onion_private_key file:

sudo rm ~/umbrel/lnd/v3_onion_private_key

Or you could rename the file so you can restore it if needed.

sudo mv ~/umbrel/lnd/v3_onion_private_key ~/umbrel/lnd/v3_onion_private_key.bak

1 Like