BTC Deposit Not Showing Up

So, I got a situation with funds being sent to my node and not showing up in the balance after one day (so far). I am hoping I didn’t lose these funds somehow, but here is what led up to now.

  1. I have an old Casa Node (v1) that I wanted to get working again. It uses the raspberry pi 3b+ and I started with the mynodeBTC OS. I kept that 24 seed phrase given by mynodeBTC when I started it up.

  2. I decided to switch over to Umbrel (v0.2.10) after testing mynodeBTC out and used the 24 seed phrase I had before. It loaded up fine on the Umbrel and is currently syncing the blockchain. To note, it even showed the recent transaction from done on the prior OS.

  3. All funding to these nodes came from Coinbase. The first funding was to the node with mynodebtc on it and it was to a BECH32 address. No issues.

  4. The seconded funding happened with Umbrel OS on it (still syncing) and that funding showed up fine. I guess Umbrel uses the BASE58 address format, so it is different from mynodeBTC OS.

  5. The third funding happen a hour after the second and I used the address given by Umbrel, which was different from the second funding event. This BTC has not showed up on the node at all, though it is confirmed on the blockchain (I checked).

  6. So where is my BTC? lol

Here is what I tried so far…

  1. I imported the 24 seed into blue wallet. It shows all the prior transactions except the last one (missing one).

1a. blue wallet also has a cool feature to check if a BTC address belongs to any imported wallets you have on the app. Weirdly, it says my original mynodeBTC address associated, but the Umbrel addresses I used are not associated with any wallet I have on there. BUT clearly one of those addressees received funding that I can access on the node (2nd funding event).

  1. And just to make it even more complicated…I opened/tried to open a lighting channel (hence the funding). This transaction was started on Umbrel and reflects in the current transaction history on the node. It looks like it is open tbh, but that is all unrelated to all this (I think).

  2. Finally, I don’t have any viruses/malware (that I know off), so I am pretty sure the address given to me by Umbrel was proper one, and I confirmed that was the address Coinbase used. Btw, does Umbrel use a different seed for future transactions by chance? Meaning, if you import a wallet, that is fine and all, but future addresses are based off a new seed or something? If so, where can I access that seed phrase or private key on the Umbrel Node?

In the end I am hoping once the node is fully synced, that last funding attempt will show up, but that will be like a week later at this rate lol

Thank you for any help you can throw my way!