My node broke while updating to v0.3.13

Node broke while updating to v0.3.13. GUI hangs on “updating installed apps” until SSD fails to respond (light no longer blinks). Tried flashing an older build with the same result.
Can SSH into it so I tried stopping scripts, removing .env and re-configuring. This worked yesterday for a similar issue but no help today.

All suggested equipment, node ran fine for over 5 months.

Have backups of lighting channels and on chain wallet but would rather not have all my channels closed as there are a lot of them.

Anyone have suggestions?

1.5 hours later and its still stuck on “updating installed apps”.
I am however able to log into the node via Zap and create a lightning invoice.

Seems there was an update to the suggested equipment since I built this node. Changed to a different enclosure and performed a manual update. Update said there was one already happening. My guess is the SSD lost power temporarily during the update corrupting something. After canceling the update status (commands used below) a manual update was successful.

Thanks to @aarondewes for all your help!


Manually updating Umbrel

To manually update your node, run these commands over SSH:

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.3.13

Replace v0.3.13 with the version you want to update to.

If the update was stuck, run this before the above command:

sudo rm statuses/update-in-progress 

1 Like