Problem with my Lightning node, stuck at start

Hi all, don’t now why but my Lightning node suddently gone offline while it was ok just the day before. Everything else on Umbrel works fine, the Bitcoin node is synched and my dojo is mixing and jam is working etc…no problem at all
But when I try to start the Lightning App though, the loading screen is stuck and my LN node is seen as offline .
I already tried to restart 2 times, without any success…

Can somebody help me ? I have the logs to share if someone is able to read it

Thanks !!!

Did you run the trouble shoot option from the web GUI settings to see the logs? You can also use docker logs -tf --tail="50" lightning_lnd_1 from the commandline if you can ssh into the node.

Yes I run the troubleshouts but I fear I’m not able to understand the logs properly. I’m not even sure I can share it safely to be honest. Are logs displaying some private infos or is it something we can share ?

There shouldn’t be but don’t post the raw output here. They are very lengthy. You need to use a service like pastebin and share the link here.

If you haven’t seen it yet, check out this post Umbrel Troubleshooting Guide

Can’t I upload the file directly ?umbrel-1673435014278-debug.log (48.0 KB)
Tell me if it’s working

And yes I already checked this post for troubleshouting but don’t really know if one the cases described is mine…

Same here, I’m on umbrel 0.5.3 and lightning node is stuck, same as OP screenshot.

In addition I got the bitcoin node also stuck, which can be the root cause of the issue.
So far I’ve ssh in, and listed the containers, to note that some containers are stuck in a reboot loop:

  • getumbrel/bitcoind:v24.0.1
  • getumbrel/electrs:v0.9.10

I’ve tried manually restarting the containers to no avail.
Any insight would be welcomed

If your BTC node is not working, I’d uninstall electrs. What is your BTC node spitting out in the logs? Is it failing to even start?

People typically prefer to view a webpage than to download and open a file from a stranger.

I found this relevant info in the log, will try the suggested workaround

Error: Invalid or corrupt peers.dat (Checksum mismatch, data corrupted). If you believe this is a bug, please report it to As a workaround, you can move the file ("/data/.bitcoin/peers.dat") out of the way (rename, move, or delete) to have a new one created on the next start.

It seems all I had to do was SSH into Umbrel and enter this command

sudo ~/umbrel/scripts/app restart lightning

All seems to be back to normal now !

Hi Louf, I just wanted to thank you for sharing that fix! I had exactly the same problem with my LND node and could not find a solution until I saw your fix and it worked! Brilliant,thanks.
Where did you get that solution from may I ask?


You are welcome,

If I remember correctly I asked a guy from Umbrel called Jim or something like that, no idea how I came to know him though, I think it was through a Bitcoiner friend of mine

1 Like

Awesome. Thanks again. It’s great to have this site and get help from people with these problems