Lnd.conf alias edit then problems

Hello, I am completely new to Raspberry Pi and Umbrel. I successfully set up the LN node and synced successfully. No problems, until I tried to change my Alias following a lightningwiki.net article. After I thought I saved the lnd.conf file I attempted to restart the node through Umbrel. I let it restart for a couple of days and it never did. I unplugged the power and plugged back in and now the ssd external drive isn’t recognized. Added to this the SSD gets to around 49C in temp and is hot to the touch when the Raspberry Pi is left on. I thought reformating it might work and just start over but Windows doesn’t recognize the drive. I also formatted the removable memory card and put Umbrel back on from the website and put it back in the Pi but it still doesn’t recognize the drive (but it’s on). Can anyone offer a direction/next steps to recover from this mistake? Thank You!

Any wrong edit in that lnd.conf file end up in breaking your node start.
Any space or wrong line will make that important file unusable.
Be careful how you edit it.
You should always keep an original copy of Umbrel lnd.conf file to be able to restore.

1 Like

Thanks Darth. I think there was a mistake in spacing somewhere when I was trying to figure out how to find the line to input the Alias line. Hard lesson learned. I am runing a 1TB Seagate FireCuda with USB-C to USB 3 cable. The connection seems fine and dmesg finds the drive but not fdisk. I combed through the Umbrel github as a last resort and executed the below:

sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/lnd/!(lnd.conf) && sudo rm ~/umbrel/db/user.json && sudo rm ~/umbrel/db/umbrel-seed/seed && sudo systemctl start umbrel-startup

sudo ./scripts/start

It kinda worked. I was able to use my seed and got to the Main Umbrel screen. It started to synch all over again (painfully slow) then froze at 5% after leaving it on for a day. Since it was frozen and as a last resort, I tried to install 0.3.14. Now it’s stuck on “removing old containers”. Looks like I will have to pull the power.

I’d really just like a fresh start by reformatting the harddrive - and avoid having to buy a new harddrive. II just don’t know how to properly do it. I made a mistake and seems I can’t recover so any help on next steps would be greatly appreciated.

If you are sure to have your seed + channel backup file (if you have open channels), you can reformat the drive and reflash the microSD card to start from scratch.

Hi louneskmt, I successfully got back into the Umbrel dashboard using the seed then ran up against the slow sync and then freeze as described above. I know how to reflash the microSD but I am totally lost on how to reformat the SSD through SSH - or on Windows? Can you direct me on where I can find steps or provide information here? Thank You.

Just an update. In Ubunu OS - I tried lsblk, fdisk, parted using command, GNOME Disks, and Gparted App. they don’t recognize the drive. Interestingly, Sea Tools for windows does recognize it but it fails to erase or overwrite. Diagnostics fail as well inside Sea Tools. Leading me to believe it might be dead unless I’m missing any other approaches to resurrect it.

If your Umbrel is already dead but you still have the channels.backup and want to participate in a test, I posted here something interesting.

Darth, I’m going to chalk the new drive up as dead including the channel and the funds on that channel since the drive is inaccessible and the MicroSD has been reformated. Expensive lesson but will circle back on if there is hope to recover that channel by normal procedures and dig into participating in your test later today. Thank You.

Here I posted a new guide about restoring a fucked up node. There are 6 methods, including one that maybe will be intersting for you