Issue with "Install umbrelOS on x86 systems"

Is there an issue with the umbrel image


I have flashed the image to several usb sticks using both balena etcher and rufus and none will boot on my pc which is running umbrelOS v0.5.4. I have checked BIOS and set the boot order correctly, even performed manual select boot from the USB drive. Always returns no bootable device.

Note: the image flashes successfully in all cases and I can read the contents of the USB if I plug it into another Ubuntu PC.

Kind regards


Yes, I’m running into the same issue. There is something wrong with the image. I have tried it on two different hardware with the same result. “blinking underbar”


Same Issue here. I now tried for hours to install it on a LinuxVM in Synology Manager and it doenst work. Something is wrong with IMG/ISO.


needs to be bump’d

1 Like

It looks like there is a new build? Have you tried it?

I will give it a try now and see. If this is the case and it is fixed, I’m a little bit disappointed that no-one from Umbrel had the courtesy to reply to this message and advise that there was an issue and a fix is underway. Communication is key to an exceptional customer experience, looking at Start9 offering now.

Looks like the issue is still there, I flashed v1.1.2 and still won’t boot from the USB drive in either legacy or UEFI modes.

1 Like

I’m also unable to boot the installer from .img file and have tried various methods both on BIOS and UEFI firmware, seems like a bad image?


I had a similar problem when I tried to install StartOS on my mini PC. Like Umbrel, the Start9 OS is based on Debian Bookworm and uses kernel 6.1. It appears this is not compatible with many newer SSDs (mine is a 2 TB WD Blue NVMe) and will not properly recognise these drives.

Check this out - [X86 system do not find boot device after installation (solved) - Support and Troubleshooting - Umbrel Community] X86 system do not find boot device after installation (solved)

I will have to give this a try to help the Umbrel image to find the Disk.

1 Like

Hi, thanks for the info, I will take a look but this is only applicable if you have actually installed Umbrel v1.1.2 which I am yet unable to do as my existing Umbrel PC will not boot from the Umbrel image on the USB stick, although is is recognised as a valid boot option. When I select it as primary boot method, there is no bootable image seen so I am assuming there is an issue with the image from


1 Like

I agree - However the forums now exposed there is a big issue with build not able to see the boot drive with a running OS and I’m sure the image team will also look into this. :grinning:

1 Like

Hi, what kind of problem do you have? What computer are you trying to install umbrel onto? I’m asking you because I have an old hp compaq elitedesk 8200 with core i5 (2nd gen) and used to run fine umbrel with the version 0.5 either over debian 12 or ubuntu 23, but the first times I tried a clean setup with umbrel 1.0, even the OS was installed, at the first boot, I just kept with a blinking white cursos on a black screen; the same happened with I tried to install StartOS.
I realized that that computer had a 2012 firmware; when I updated to the latest one (2019), now it worked and right now I am syncing the bitcoin node inside umbrel 1.1, so I guess it is not a problem with all x86 systems.

1 Like

Sounds promising. What changed in the bios between versions? My bios is 2010 and the PC will load Ubuntu 23 / 24.04 with no issues. I’m confussed why umbrel 1.1.2 is having so many issues with older hardware?

Have you tried turning off secure boot?

Yes, tried disabling secure boot too, but thanks for the suggestion. Looks like Umbrel have some issues with their new release. Thankfully I’m still running the old version, probably a blessing that the upgrade wouldn’t install from what i’m reading on the forums.

From my experience all of my trouble came from adjusting my BIOS settings involved with virtualization. It’s possible older hardware just is not suitable for the virtualization demands

Good news for fellow KVM users (Proxmox, QEMU, Virt-Manager Linux Native Virtual Machines)

I found the right combination of tricks to boot the Umbrel installer image

  1. Converted the img file to a qcow2 disk, mounted this this as a second disk
  2. Create VM with UEFI bios, set boot order so the installer goes first
  3. Enter the Virtual Bios (F2) and disable secure boot from there (I personally had expected this to be a VM level setting, but it’s in the virtual bios)
  4. Reboot the VM and the installer should come up


Going through the rest of the install now, hopefully we’ll now be able to package and test Lightning.Pub for Umbrel

1 Like

I am not really sure. All I know is that the old bios firmware let me run common distros like debian, ubuntu, arch and so on, but not one server, like umbrel or startOS, when I upgrade the firmware to the last version (2019), then the hp elite desk could boot, and I always thought that secure boot had something to do with it.