[umbrelOS 1.1 update] Fail to boot from usb stick

I am currently running umbrelOS 0.5 on Ubuntu server 22.04 and I’m trying to follow the linux-update guide.
However I can’t boot up on my usb stick that has the umbrelOS 1.1 image in it. At first I thougt there was some problem with my usb stick, then I tried using another one, but no success. Then I tried using Rufus instead of Balena Etcher to make the bootable usb device, but the result is the same.
The usb stick can be found in the bios, but when I select it, the boot falls back to the previously installed umbrel 0.5 (on top of Ubuntu server)
I’m not sure if my HW is too old for this new version of the OS. My motherboard is a PCWare ipmh61r1, CPU: Intel Core i3 2100

Thanks for your help.

Check the BIOS settings if it’s booting from Legacy or from UEFI. Set it to UEFI (if it’s not already), and see what happens. Also maybe try booting from that USB stick from a different machine, see if it works there, to understand if the problem is with the USB stick or not.

Hi @matrix_stuff, thanks for the reply. I don’t see any option related to Legacy or UEFI in my BIOS settings. Screenshot attached.


UEFI Boot Device Priority shows an empty menu.
Regarding my USB stick, yes, I can boot the umbrelOS 1.1 using it on my daily driver PC (which has a Gigabyte Z370 HD3P motherboard)
I have already trying extrating the .iso before flashing it and also played a little with Rufus’ options but no success so far.

Check the other menus like “security” and see that it doesn’t try to boot in secure mode. Also, maybe in Advanced menu there’ll be some relevant options, maybe USB related configs. If the stick works in another computer then it’s the current computer that’s causing the issue, not the stick