Introducing the official Nostr Relay app

For those of you who use Nostr, you’re going to love this new official Nostr Relay app we built. Your Nostr activity can now be backed up in real-time. :call_me_hand:

See it live in action:

Connect your Nostr clients, such as Damus, Astral, and Amethyst, to your private relay for seamless backup of all your activity on Nostr, and watch it hit your relay in real-time.

In Damus, go to Settings > Relays to add your Relay URL.

Tip: Install Tailscale on your Umbrel and your devices for an uninterrupted connection between your clients and your relay, even when you’re away from your home network. Enable Tailscale’s MagicDNS and use ws://umbrel:4848 as your Relay URL.

Twitter announcement: https://twitter.com/umbrel/status/1622591145481236480

2 Likes

enabled tailscale magic dns but when i test out the regular ip address the relay is connected and works. but when i use umbrel:4848 as the relay then it does not work.
tldr: relay with long ip address works. but does not work with umbrel:4848 as the relay.

Can you double check Tailscale hasn’t set your Umbrel’s name to something like umbrel-1? You can see it here: https://login.tailscale.com/admin/machines

I posted this on Reddit before I remembered that this is the better place to come with questions!

I’ve got a question about this new app. Let’s say I wanted to point a domain name at my umbrel:4848. That way I can let friends use my relay without needing to join my Tailscale network. Is there any inherent security risk in making the nostr app publicly accessible?

If it makes a difference :point_up_2: I’ve got a virtual private server forwarding traffic down a WireGuard tunnel to my home network where nginx proxy manager handles ssl termination and sends the request along to the nostr relay app. No ports are open on my home router.

My thinking is that there’s nothing private on the app page that gets exposed (including the relay address itself) and there aren’t any administrative functions exposed either so it should be safe but I did want to double check that I’m thinking about this right.

1 Like

its a regular “umbrel” and below that my login for tailscale. its not umbrel-1

I could do with some help please. I tried for a few hours yesterday. Eventually i realised the current nostr relay wont work with Websites, only apps for now. I have amethyst on android.
My tailscale is working fine, for its other duties, but I can get the nostr relay to work. it just stays “red” on amathyst.
I even tried adding a port forward on my home xfinity gateway for 4848 to the umbrel. no dice.
I have turned magic dns on and off a few times.

So: on my phone browser when not at home , but with tailscale active:
I cannot resolve umbrel.local but i do resolve the ip4 address, (if i use the umbrel as my exit node.) If umbrel device is not set my exit node, i cannot resolve its tailscale IP.

so: on my phone, outside of home: IF i have tailscale running and the exit node is my umbrel, i can resolve the ip:4848

About 2 hours of testing have now discovered that, i got it to work !! (while writing this post!) : here is how: I had to goto astral.nija (and enter my private key (bad, but I am frustrated now) ). add the relay as:
ws://MyTailscalePrivateIP:4848
it doesnt work if you try add it thru amethyst.
Then goto amethyst, logout and force close. Login again to amethyst.
write a post in amethyst . somehow it now shows up on my own nostr relay !!!
(oh at some point I removed the port forward on my home router. wasnt needed) I assume thats a tailscale functionality/feature.

hours and hours of trying!!
I dont think my posts from websites like astral.ninja do save/appear on my umbrel relay. (even after getting the first amethyst post in) . I dont know why, and I’m exhausted at this point.

:confused:

1 Like

when you say mytailscareprivateip:4848 you mean the tailscaleprivateip of umbrel right?

I enabled tailscale and magicDNS but still can’t post to my relay when not connected to my home network.

I can connect to ws://umbrel.local:4848 when connected to my home wifi, but it’s yellow when I am off my wifi, even when connected to tailscale VPN on my phone. Can’t figure it out!!!

apparently you are suppose to type ws://umbrel:4848 and not ws://umbrel.local:4848 but both dont work for me either

1 Like

Yes. The umbrel device. It’s notable that some people do get umbrelDeviceName.local to work but I cannot.
So I tried the IP.
I do recognize that some issues are tailscale ones, but once I am using the IP:4848 , the Nostr node still doesn’t get/store my posts.

They actual mean the network name your gave your umbrel. Which is not always just umbrel…

@anon56546899 @dackdel @aaron8819

Sometimes when outside of your home network, mobile devices may have intermittent connections with VPNs- and for instance if you’re on iOS it is incapable of running multiple VPNs at the same time and won’t work.

Here is some troubleshooting for Nostr Relay:

If you’re outside of your Home Network, make sure all other VPN apps are turned off (uninstall them if necessary to isolate the issue). Uninstall and reinstall the Tailscale app on both your Umbrel and phone. Reset your network settings on your phone or just hard reboot your device.

Double-check to make sure MagicDNS is enabled for Tailscale, you can confirm here: https://login.tailscale.com/admin/dns - the button will be red if enabled, it will be green if it’s disabled and you must to turn it on to use Tailscale and Nostr Relay remotely. Then using your Nostr Relay URL ensure it is copied exactly how it appears in your Nostr Relay app. Once added give it a couple minutes to turn from a yellow dot to a green dot in your app, closing and re-opening the app may also help.

Amethyst Client added support for ws:// four days ago in version v0.14.2 on February 10th as well, ensure you are running at least this version or later, currently it’s on v0.15.9 you can update to and try again. If you are using a different client make sure it has ws:// support or it won’t work yet unfortunately.

For connecting on the same local network the Nostr Relay URL should also work, make sure your mobile device is not connected via cellular or a different Wi-Fi network. You can also test by using a client on a different device and adding the relay there to isolate if it’s an issue with where you primarily connect from.

If you’re still having issues, you can make a post detailing what client you’re connecting from and any other details and we can work to resolve these issues ASAP! Feel free to DM me on Telegram as well, happy to further troubleshoot: https://t.me/usernameisJim

ok so there is no problem on login.tailscale.com (magic dns is on and it says ‘umbrel’) the issue is on the nostr app. it only shows the relay url as ws://192.x.x.x:4848 and not ws://umbrel:4848

Hello,
is there a way to use it outside our network without Tailscale? I setup at my registar nostr.mydomain.tld to arrive to a server on my network (same as Umbrel) and then reverse proxy to my umbrel_IP:4848. But then if I open nostr.mydomain.tld (from the network or not), I arrive on the Nostr Relay page but it says always: “Connecting to relay…” and never get connected.

Is there something else to do? Remove the proxy in Umbrel like for Invidious?

I had this problem too. It doesn’t make sense to me that say Damaus would understand Umbrel:4848

That’s not a valid reachable endpoint.

Instead I used the public IP that tail scale magic dns creates for you.

That works in Damus.

Perhaps this is a consideration you might want to consider?

i.e., you’re specifying:

  • ws://MyTailscalePrivateIP:4848

But maybe you should accomodste and use this instead:

  • wss://MyTailscalePrivateIP:4848

I hope that helps!

#tallship #umbrel #nostr #relay #FOSS

:sailboat:

.

Is there a way to use this relay to post messages not from an existing client but from say a python script?

Does anyone have a pointer to code that does this or a pointer that explains how?

does it work when you are not on your local network?

you and I have had the same issues before, I see. :stuck_out_tongue_winking_eye:

Hi there and thanks for the relay.

Question - I’m moving my umbrel installation to another system - how can I move my relay activities to a new system? Does it make sense that there would be a function in the app to backup to a tarball and be able to restore it elsewhere from the WebUI?

Thanks!