Nostr relay not connecting

Hi everyone,

I installed the nostr relay app but it’s stuck on “connecting to relay”. Any troubleshooting suggestions?


Can you try to reboot your node via System > Restart?

Then wait ~5-10 minutes

Let me know if this works and we can continue to troubleshoot

Rebooted my pi 12 hours ago, shows connected, but messages not backed up to my ws://umbrel.local:4848

rebooted but still having same issue “connecting to relay”

Anyone else having this issue?

1 Like

Seems to be working now… not sure what I did exactly. Restarted the node + removed/ re-added the relay to my nostr profile.

1 Like

@anon56546899 @flea What Nostr clients are you all using? Do you mind to share a screenshot of your Nostry Relays screen? If you’re on Tailscale it must be enabled on the device and can check MagicDNS is also enabled here:
If you’re using local network Tailscale should be off, as well as any other VPN on your client device… Try restarting your client app and then re-adding the relay as well as a troubleshooting step, happy to further assist!

I’m having the same issue. I’m using the client Iris and Snort with the same result. The client cannot connect to the relay. I’m on a local network, Tailscale is off and I’m not using any VPN, if I try to access from the same web browser to http://umbrel.local:4848/ I can see that the relay is running.
I’ve tried restarting umbrel, restarting the client and re-adding the relay without success.

Having similar issue. Rebooted umbrel, reinstalled Amethyst. Restarted tailscale on my phone.

However, I see Amethyst (and a websocket tester) hitting my local relay (i.e. wss://mytailscaledomain) when I add it. The logs (via docker logs -f containerid).

2023/03/07 16:06:41 Accept: TCP{someip:43660 > mytailnetIP:myrelayport} 60 tcp ok
2023/03/07 16:06:41 Accept: TCP{someip:43660 > mytailnetIP:myrelayport} 52 tcp non-syn
2023/03/07 16:06:41 Accept: TCP{someip:43660 > mytailnetIP:myrelayport} 569 tcp non-syn

Am I missing something on my umbrel?