Install UmbrelOS as a VM (virtual machine)


How can i install UmbrelOS as a VM? i can’t boot a VM with the ISO file to go through the installation and apprently I can’t passthroug the installed harddisk into my virtual environmet

1 Like

It’s a bit tricky as the umbrelos-amd64.img.xz image seems not to be compatible with VMs. I got it to work using the umbrelos-amd64-usb-installer.img.xz by following the steps below.

1 Like

What virtual envirnment do you use?

The solution is in this topic
Umbrel 1.1 on Proxmox - Support and Troubleshooting - Umbrel Community

1 Like

This is not helping for VM-Ware :confused:

change EFI to UEFI in firmware and see if that helps

there is no option for UEFI in VM-Ware

when you make a new VM are you then able to chooce if it should be BIOS or UEFI in the configuration?

no I have only those two options at all

okay, have you then tried the BIOS option?

yes of course :slight_smile:

I tried to convert to iso via different tools
on the mac via DiskUtility and on linux via gcdemu , iat and ccd2is

hmm okay, i used the Balena software to make a bootable USB and then booted my VM from the USB.

Are you trying to boot directly from the ISO like with a windows ISO?

1 Like

That is the only way it worked for me too…

I am using UTM for Mac and Virtual Machine Manager (QEMU) on Synology.

1 Like

Did you get it to work?

Unfortunately no :confused:

mon VM-Ware does not accept the inserted USB as a boot partition source for the new VM

Because I was not able to take my USB stick offline (removeable device) I used a SSD with USB adapter. After flashing the SSD with belenaEtcher, take it offline in Diskmanager and connect it as physical disk to Hyper-V VM. I adjusted the boot order In VM settings, deactivated ‘secure boot’ and snapshots for the umbrel installation, afterwards I enabled only snapshots and removed the physical disk.

Oh okay, i use proxmox not VMware.

I managed to install umbrelOS 1.1.2 on Ubuntu 22.04 using virt-manager:

1 - Download the usb installation image file and uncompress it

xz -d umbrelos-amd64-usb-installer.img.xz

2 - Run virt-manager and create new VM

Select “Import existing disk image” , select the umbrelos-amd64-usb-installer.img file and choose debian 12 as OS type:

Configure Memory & CPUs. Select “Customize configuration before install”:

On the “Overview” tab, change the default BIOS firmware to “UEFI x86_64: /usr/share/OVMF/OVMF_4M.fd” (and apply):

Last, add some disk (“Add Hardware” on previous image):

Unsolved problem

I managed to boot & install umbrelOS 1.1.2 but… I found some unexpected problem with the dns.

With this i was able to Install 1.x, but no luck with booting. Ich will give it up for now and look into it again in some month. So long 0.54 does it for me.

Once installed, remove the VirtIO disk created from the img file. It is configured by default as first boot device and you no longer need it. It should boot from the second VirtIO disk (the 20 GiB in my example).