Install umbrelOS on a VPS

I’ve been waiting for months for this new update for all Linux system, I already ordered and paid a VPS to accommodate the new Umbrel OS, and it seems that for the install it requires to plug a USB stick!
What happened to the old curl command to install?
How can I install umbrel OS on a VPS where I have no physical access?


Hi, I am also wondering how to install it in a VM. I see a .img release here which is not a usb installer. Unfortunately I was not able to get it ro run with VirtualBox. Hopefully there will be a VM image soon to ease the installation.

1 Like

I ran into the same issue trying to boot it in a VM on my Synology. The .iso cannot be read from the BIOS, both legacy and UEFI.

Steps I tried:
-Downloading the non-usb .img.xz
-Unpacking to .img
-Converting to .iso

Unfortunately, my VPS provider doesn’t support booting from your own .iso but only preinstalled images (Ubuntu, Debian…)
And I already paid the VPS for one year.

Sad, very sad.

Your comment is OT. I actually wanted to use Umbrel on a VPS for a media server and more.

1 Like

I just managed to get to the installation menu of UmbrelOS in a virtual machine. My way:

  1. Choose one of the images as boot image (just as a placeholder, they do not seem to work with VMs)
  2. Flash umbrelos-amd64-usb-installer.img.xz on a physical usb drive with Balena
  3. Inject the usb drive into the VM
  4. Boot up the UEFI, it will not boot into the boot image
  5. Type ‘exit’ and enter
  6. Open boot menu
  7. Choose usb drive to boot into

This method won’t work for a VPS as most of them won’t allow you to boot your own image.

Sorry, what you mean “OT” ?

Your comment was Off Topic.



I’m at in the same scenario, i use OCI, the free tier VM that i get there, is ARM/AARCH64 architecture, and there is no way to boot an image in their console. Please, if you solv this, share with us.

I might be mistaken but the latest AMD64 image can’t be installed on an ARM device. I think the RPi is based on ARM, maybe you can use its image and try that out on a VM.