How to update to umbrelOS 1.0

umbrelOS 1.0 is here for Umbrel Home, Raspberry Pi 4, and Pi 5 users!

Here are the step-by-step instructions on how you can update.

For current Raspberry Pi 4 users on umbrelOS 0.5

To make use of umbrelOS 1.0’s new architecture, a re-install of the OS on your microSD is required due to significant under-the-hood changes. Specifically, there’s a new partitioning system designed for increased reliability of the OS. Don’t worry; your apps and data stored on the external drive will remain intact.

For current Raspberry Pi 4 0 users on umbrelOS 0.5, please follow the update instructions here by clicking the ‘How to update’ button: How to update to umbrelOS 1.0

For new Raspberry Pi 4 and Pi 5 users:

Please follow the installation instructions on our website.

For Umbrel Home Users on umbrelOS 0.5

Umbrel Home users, updating to umbrelOS 1.0 is straightforward through the UI. Simply navigate to umbrel.local > Settings > “Check for update”, and click ‘Install Now’.

For Linux users on umbrelOS 0.5

If you installed umbrelOS via the curl command, your update is on the horizon. Please wait until April 2024 for the release. You may disregard any system update alerts until then. Stay tuned for instructions or sign up on our website to be notified directly.

6 Likes

And for rpi4 users who boot from the SSD and we don’t have a microSD? How do we update? Thank you so much

1 Like

Existing Pi5 user. running 0.5.4 version running from USB SSD. Downloaded the umbrel os image, used balena. booted making sure the SSD is read first.
it stops at umbrel login.
Initializing XFRM netlink socket

not able to upgrade. any other alternative? I hope I dont have to re-synk all the node again…

1 Like

How do I connect to wifi? In the previous version, I just put the wpa_supplicant.conf in the sd card, and the raspberry connect to my wifi network. It’s not working in this new version.

3 Likes

Same here, I’ve had to use ethernet for now.

1 Like

OK, I’m using Umbrel loaded on a mini PC running Linux.
So although my machine is saying I have an update, I need to ignore it.

Do I need to ignore the update to the Bitcoin app too?

Thought I would chime in as I just completed the upgrade. Instructions worked fine for me on a Pi-4 “The Bitcoin Machine” device. I flashed the card (copied it first) then rebooted and was greeted with a new user sequence - had to create a new user name and password which was confusing. Umbrel loaded and - no apps. Nothing. I did see a notice for an update to Umbrel OS 1.0.0 which I thought I had just completed. Clicked install, the update progress report ran and after about 5 min I was back at the login screen. Logged in with my original password and boom I was in and all my apps were there - though they were all in a not running state. Waited until they reported as started and have been opening each. So far so good - BTC node and LN node both seem fine. Will report back with any app issues.
My TBM LCD was wiped out as it lived on the SSD with Umbrel. I followed the steps from here - Bitcoin Machine LCD (v 0.5) - Run your Bitcoin and Lightning Node to reinstall (which I have done before) . I did get one weird error with Python and a managed environment but it seemed to complete as expected. Will update after checking all the apps and rebooting.

1 Like

The update for umbrelOS 1.0 for other devices will arrive in april.

Run the update for Bitcoin app for fix bugs or other.

So my TBM display is officially no longer working post upgrade. Investigating will reply back once I know the issue and to see if there is a resolution.

Hey @goldbug, you can just ignore the notification for now on your custom mini PC install. It’s okay if you click “Install” though, nothing bad will happen. Your device will attempt to download the update but will stop and show you an error when it realizes you aren’t able to update yet.

1 Like

Same problem for me. No obvious way to set up the WiFi on my Raspberry Pi 4 :smiling_face_with_tear:

New Linux install is broken because of a failed ssl_version. How can I install UmbrelOS to the previous versions using the script?

Traceback (most recent call last):
  File "/usr/local/bin/docker-compose", line 8, in <module>
    sys.exit(main())
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/main.py", line 81, in main
    command_func()
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/main.py", line 200, in perform_command
    project = project_from_options('.', options)
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/command.py", line 60, in project_from_options
    return get_project(
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/command.py", line 152, in get_project
    client = get_client(
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/docker_client.py", line 41, in get_client
    client = docker_client(
  File "/usr/local/lib/python3.10/dist-packages/compose/cli/docker_client.py", line 124, in docker_client
    kwargs = kwargs_from_env(environment=environment, ssl_version=tls_version)
TypeError: kwargs_from_env() got an unexpected keyword argument 'ssl_version'

My Umbrel (Pi4) is now showing me that the system uses 723GB and the Bitcoin Node uses 0B.
All the other storage usage seems to be displayed correct.

Exactly when during april is it gonna be available for custom Linux installs?

1 Like

Hey all, I just updated my Raspberry Pi 4 to the 1.0 version and my apps is not starting, it says “Not running” for all apps. Is anyone facing this problem?

I’m using a Pi 4. The initial flash of my SD card failed with BalenaEtcher. I tried again and it worked. When I booted up on umbrelOS 1.0, it prompted me to create a new account. My apps are not showing. It doesn’t even recognize my SSD that was connected and holding old data. What do you all recommend?

1 Like

Exact same issue here on my Pi 4 too. :cry:

I might just revert back to 0.5 for now.

I can’t do this update on my pi 4 with 1tb ssd.

Raspberry Pi 4 8G, Upgrade to 1.0 successfully from 0.5.4.

1 Like

Hi @Chuskas I assume that means you set up umbrelOS with our curl -L https://umbrel.sh | bash command? Unfortunately the 1.0 release update won’t be available until April