Introducing umbrelOS 1.1 with Terminal, the umbrelOS Beta Program, and more

umbrelOS 1.1 is now out with Terminal, umbrelOS Beta Program, several enhancements, and bug fixes.

umbrelOS 1.1 is rolling out now as a software update to Umbrel Home and Raspberry Pi users.

Users on other devices - stay tuned! We’re on track to transition you from umbrelOS 0.5.x to the latest version this month.

Terminal allows you to run custom commands in umbrelOS or within a specific app.

And with the umbrelOS Beta Program, you can opt in to receiving beta updates to gain early access to new features, and help us refine them.

Also new:

  • Start, stop, and troubleshoot apps by right-clicking them.
  • View an app’s update progress on its app icon on the home screen.

Bug fixes:

  • 2FA prompt not being visible on the ‘Login with Umbrel’ screen for various apps.
  • Executing custom commands in app containers on Raspberry Pi.
  • App widgets disappearing from the home screen during app restarts or updates.
  • Improved error handling throughout the user interface for better stability.
  • Widgets not opening apps if their corresponding app fails to respond with widget data.

Twitter announcement: https://twitter.com/umbrel/status/1780604544868815269

5 Likes

Can’t wait for !the update on other devices!

5 Likes

I do too!

Thank you for the new update. Is NVMe now also recognised?

1 Like

Does this update require to flash sd card again or it is only a regular update from the UI?

No, is not required. You can start it from the GUI. It takes only a few minutes.

So it is April 18th and where is the information on installing on other hardware? Let’s have more updates.

1 Like

So I’m stuck here and can’t update. This is the first time something like this happened. Pi4.

Any suggestions? Should I refresh the page or power off?

1 Like

fix the correct memory ram usage

Did you fix your issue?
I have not tried to update my Umbrel yet.

1 Like

Yes. I actually unplugged it from power and restarted. It booted to 1.1 :confused:

Still no out-of-the-box WiFi functionality for Raspi although it was promised for 1.1? Or is it just hidden so well that I couldn’t find it? The same manual hack as for 1.0 still gets WiFi working.