How to update to umbrelOS 1.0

No, it simply burned the image (.img) to the USB and in the rpi4 configuration I told it to boot from there. I did it wrong?

Oh I see, yes you will need to use a SD card that you can leave in the Pi with this image.

Hmm, I think I will avoid the update in that case until this is fixed.

1 Like

Teething problems with very new software or hardware cannot be ruled out.

umbrelOS 1.0.0 runs on the Raspi 5, so that’s all I can do for now.
The node with 0.54 is running flawlessly so far.
Never touch a running system.

I still have an Orangepi5, let’s see if I can get it running in April with linux and umbrelOS 1.0.0. I still have problems with ssh and Tor connection to the node.

Sigh I knew I should have waited, c’mon guys why ship a workflow that doesn’t work

I got umbrel 1.0 on my sd, put it in my rp4 running 0.54 then it made me create a new user, now
nothing works
Additionally, i tried going back to 0.54 and I get

Error: Failed to start containers error. This is just ridiculous…Going to try and going back to 1.0, but like seriously??


Updated 3 of my Pi 4’s, expecting a release like this to have had some basic testing done…

So far, it’s been a complete sh*tshow…
The first unit wouldn’t let me login with 2FA, just didn’t accept it, so had to downgrade to 0.5.4
After downgrade, the docker config simply didn’t have a subnet set, and we could only get the Umbrel containers running, all other containers (BTC, LIghtning etc.) just no joy. After restart managed to get back in, but then no containers so no App running. Docker Overlay is there for the Apps, but not accesible obviously, then it simply crashed. So have given up on that one… will have to see how I recover btc and lightning channels if at all.

Second one, post upgrade managed to login (no 2FA on it), no Apps visible, App store crashes every time, check for update fails with an error (consistently), Bitcoin node shows “Starting” after 3 hours, with nothing to show for it. Lightning node wont startup.

The third unit, same as the second, Bitcoin but wont start, App store and update gives an error.
Have wasted a day, and probably lost any BTC in the Bitcoin wallet or Lightning channels which sucks.

The financial loss, if it is confirmed, is my own fault, but the time wasting and all the issues, well, I expected better from Umbrel. Surely a standard Pi 4, with SD card and an SSD for the data, doing multiple upgrade tests would have covered some anomalies. I run a dev, qa and devops team in Saigon, we work on big platforms, I would be embarrassed to death if we came out with so many issues. I appreciate its a major release, but issues with all 3 units… that’s just BS.

Frustrated as heck!


In previous installations of Raspberry Pi, I was able to do a clean installation directly onto the USB disk.
I tried using Balena Etcher to create the USB disk, but at startup it boots up, but after a short time, it constantly asks for a reboot.
I don’t have a microSD card.
How can I solve this? Thank you.

I am planning to flash a new SD card and leave the 0.5.4 alone, in case I need to go back to a previous version.
Would this help to avoid all the issues I’ve been reading in this post or it will not avoid the issues after all?

1 Like

Rasp. Pi4 here.

In order to headless connect to umbrel via IP after the update I had to delete my static umbrel IP in router settings because it wasn’t connecting to router.

Also, If I try to set again the same static IP than before it doesn’t work, I had to set a new number different than before as an static IP.

A lot of times when I boot up the system, umbrel doesn’t recognise mi SSD, only the SD card, I need a few reboots in order to get my SSD recognised.

I also noticed a Transmission download speed noticeably drop, I had to change to qBitorrent.

Finally I got a system crash a few minutes ago when I entered to umbrel via tailscale with my phone (never happened after the update), so… I will need to manually power off my raspberry when I get home and pray that reads my SSD in the first try.

Resume, I didn’t recommend to update at least for rasp. Pi4.

This update is a disaster, I don’t recommend it to anyone.


Nice, but how do I get my wifi connection back?


Same here. Managed to get past the environment issues by following the steps listed here. But still getting an error when the boot.txt file is attempting to be modified. Appears the entire sdcard might now be write protected. Still investigating though.

Can Umbrel please post a like for the 0.5.4 image so the people that are having trouble can try to revert to a working version??

I concur with some of the comments above, if you are running a Pi 4 with 1 tb SSD , DO NOT UPGRADE


Pretty similar situation here for me. Running BTC + LN node on Pi-4.


  1. Copied card
  2. Flashed image
  3. New user sequence
  4. No apps
  5. I could not update, said I was on the latest version.
  6. Rebooted
  7. Was asked for MFA that I had not set up under step 3.
  8. Old dashboard with all apps installed but “Not running”
  9. Waited for ~15 minutes
  10. BTC node is starting and resyncing…

Looks like all is okay for me.

Same. Got the install to go through until the /boot temp write and then error. Tried to make /boot rw but:

umbrel@umbrel:/TBM/TBMLCD-v0.5$ sudo mount -o remount,rw /boot
umbrel@umbrel:/TBM/TBMLCD-v0.5$ mount | grep /boot
/dev/mmcblk0p3 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)

Umbrel has it locked somehow which makes sense as they warn you SSH is for TS only and any changes will get overwritten on system update. So, this is by design BUT it breaks our use case.

Think you might be able to take the SDCard out, mount it on a computer and manually modify the boot.txt file but I don’t have the time to disassemble the bitcoin machine right now to try that. Maybe later tonight.

Tryed and had issues ‘Not Starting’, going back to old install. Please let us know when you have the bugs worked out, and I’ll try again.


Just tryed an old version and now everything is F’ed up!
Got an error saying “Failed to launch containers” after restoring a backup made before upgrading.
DO NOT USE Umbrel 1.0.0


Can anyone from Umbrel comment on how to get the Wi-Fi working again?


It would have been nice of you to let people know that once they tried the upgrade they could not go back to the older version! I now have to redownload the entire blockchain which will take me over four days because your software made changes to my SSD.

1 Like