UmbrelOS version on MicroSD and External Hard Drive are out of sync

Error: Version mismatch

The version of UmbrelOS on your microSD card is not compatible with the version of Umbrel on your external drive.

Anyone got any ideas on how to resolve this?

Many thanks!

I got the same error :(. Looks like something in v0.5.0 isn’t migrating properly… I fixed it by ssh-ing into my umbrel and running

cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.4.18

It’s a shame, I’m excited for all the new goodies in v0.5.0, not sure why it isn’t working right.

I think it has to do with, when I run sudo apt-get update I get errors caused by when I tried to install Kodi at one point on the raspberry pi:

umbrel@umbrel:~/umbrel $ sudo apt-get update
W: GPG error: jammy InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6D975C4791E7EE5E

I fixed this by adding the missing signature (note the signature id is pasted after 0x in the script below):

  curl "" | \
    awk '/-----BEGIN PGP/{p=1} /-----END PGP/{print; p=0} p==1{print}' > key.txt;
  sudo apt-key add key.txt;

Then I stopped all of my running docker containers

Now cd ~/umbrel && sudo ./scripts/update/update --repo getumbrel/umbrel#v0.5.0 works fine.

1 Like

Very good stuff, this fixed the upgrade process(0.4.18 -> 0.5.0) for me.