How to update to umbrelOS 1.0

Why are there so many versions of the Umbrel 1.0? It started with the fix 1.01, then 1.02, 1.0.3 and now 1.0.4. Does this mean that the software is still in testing to find the right update?

Thanks @p0die and @lukechilds I inspected the SD but my limited technical skills do not allow me to identify if there are any partitions as you mentioned. Any advice/suggestion?
In My SD there seem to be the following two drives:
In BOOT-A there are these files:

In CONFIG these:

Thanks again

Hi mayank,

is there any specific timing plan when could we expect the next release were umbrelOS will be compatible with the new Raspberry 5 new NVMe pcie port?

Thanks!! :smiley:

Hi @isvanmc
version 1.0.4? where is it? I missed that. can you point me to the right direction? or is it the one available in thanks

Go to the first message in this thread and click the link “How to update to umbrelOS 1.0”
Definitely has been changes in the update version but nothing is shared in the open here.

My question is: if version 1.0.2 was the solution like lukechilds ensured, why do we have now 1.0.4 and nothing is mentioned?

Thanks mate.
The update is being pushed as we speak through a pop up message in the Home Screen/dashboard. just updated the OS. the update seems to have fixed the the problems I was facing and now all my apps seems operable. only needs time for bitcoin node syncing!!

1 Like

def. 1.0.2 was not the solution (I installed it but didn’t work). but 1.0.4 seems to have fixed the issues. hopefully for everyone.

1 Like

Does umbrel 0.5 work with raspberry pi5 and an NVMe hat? I have a Pi 5 and 4 TB NVMe hat. NVMe Base for Raspberry Pi 5 - NVMe Base

No I don’t think so. You need Umbrel 1.0 for RPi5 to work.

1 Like

Waiting a few more days to be sure everything works before updating. Thanks to the early testers and happy your problems are being solved.

If you want to use RPi 5 with autoboot on the SSD, you can see how to do it in this video. Install the RPi OS first and when version 1.0.4 of Umbrel for Linux comes out, just follow the usual instructions on the Umbrel website.

I already auto boot my RPi 5 from the NVMe drive. Not a big deal.

And following instructions from the Umbrel Website will not work with 1.0.4. Period. 1.0.4 doesn’t know how to access the NVMe drive connected to the PCi port and REQUIRES a MicroSD card to boot… I’ve tried various ways to get around that but it’s a kernel issue on their “flavor” Linux.

The example shown is for Linux and not for RPi. Therefore, you won’t be able to say anything until the Linux version is ready in April.

It’s April, is the Linux version available yet?

So you’re assuming UmbrellOS is going to run as a Docker container App on other hardware? Guess we’ll see at some point when/if they hit their stated April target.

But the trouble I have has nothing to do with that. It’s all about supporting RPi 5 on the current 1.0.x release.

Just saw the “no Linux version” posting…not really surprised…

Just have a look at the website from time to time. It will be published there.

Rikser, the “no Linux version” comment was in response to a now deleted posting that had some allegedly inside information about Umbrel changing their plans. I won’t go into details as the posting was removed very quickly, and was possibly not intended for public consumption at this time. And I’m guessing that the Umbrel team may still be debating things, which they have the right to do, in private.

I will say that happy path testing and a pretty UI doesn’t make for an OS that is stable and functional. Any OS, no mater how nice it looks, that isn’t predictable, stable, and functional is not something I’ll ever use to run serious/critical applications on. I do watch/check their web pages every day to see how things progress. But for now I’ll stick with Bookworm and Bitcoin Core installed from scratch on my RPi 5 with NVMe SSD…not flashy, but no issues at all with performance, predictably, or stability…

1 Like