Can Umbrel 1.0 use wifi?

I recently installed Umbrel 1.0 from the guide onto my PI 4 and had no issues with it. (I’ve been running PI OS before this). I don’t have access to an ethernet connection so, I was trying to setup wifi by adding the ‘wpa_supplicant.conf’ file, like you normally do for PI OS.

I can’t seem to get it to work unfortunately no matter how many times I’ve tried. So after that, I tried installing it via the ‘curl’ command in Debian and Ubuntu and get the error: “UmbrelOS 1.0 is currently only compatible with Umbrel Home, Raspberry Pi 4 and Raspberry Pi 5. Support for more devices is coming in April 2024.”

Has anyone been able to add a form of the ‘Wpa’ file and gotten wifi to work on 1.0? If not, all I can think of is to wait until April and try again the other way. (Maybe I’m just confused when it comes to that…idk). Not sure what to do.


same issue for me with pi 4, no damn wifi


UmbrelOS 1.0 is based on Debian 12 (bookworm) which doesn’t support the wpa_supplicant.conf method anymore.

I’m also struggling to find a way to get it working :see_no_evil:

1 Like

I wouldn’t have updated to 1.0 if I knew I would loose the Wi-Fi function. It would be really nice to have someone from Umbrel comment if there is a fix in the works for this issue, or if we are just eternally screwed.


Dang, that’s frustrating. Hopefully they will figure something out when it comes to being able to use it via Wifi. I have tried out CasaOS which works good with my wifi connection. I just really wanted to use Umbrel.

Do you feel as if the older version of Umbrel you were using before, is reliable as a daily driver? I might just look into that, if it doesn’t have a lot of issues. I do hope they are able to sort out installing 1.0, for the people who can’t setup an ethernet connection.

The only other way I’ve thought of using it, is by making a ‘ethernet bridge’ (I think it’s called) with one of those cheap portable routers. I want to setup regular ethernet but, It’s going to involve running the cable through some walls (I don’t have any drills or the stuff needed for it) and, I just don’t have the money for that at the moment.

Maybe they just decided using it through wifi, would take a big performance hit. I don’t plan on using it for anything heavy so, I’m fine using it on wifi.

@Woolfe25 As far as I know it’s not possible to revert by the an old version. I warned a bunch of friend, DO NOT UPGRADE to v1.0, there is no going back!

1 Like

Hey everyone,

Apologies for the confusion. In our effort to streamline the update process and provide a more robust user experience, umbrelOS 1.0 has transitioned to using Debian instead of Rasbian for both Raspberry Pi 4 and Pi 5. This change means that traditional methods for configuring Wi-Fi, such as raspi-config, are no longer applicable.

We are actively working to integrate WiFi functionality directly into the umbrelOS user interface. However, this feature is slated for release with umbrelOS 1.1, which is at least a month away.

For the time being, using nmcli is your best bet for configuring Wi-Fi. However, note that any changes made through SSH, including those made with nmcli, will be reset by the next OS update.


Thanks for the reply. I’ve got both of my Pi 4’s upgraded to 1.0 and working on Wi-Fi now. I was pulling my hair out before.

FYI, for others that come across this thread, you may use the command below to install the necessary WiFi drivers on your Raspberry Pi:

sudo apt-get --yes install firmware-brcm80211 && sudo reboot

Then to connect it to WiFi:

sudo nmcli device wifi connect <your-ssid> password <your-password>

Note: This is experimental. We haven’t extensively tested these drivers on the Raspberry Pi yet. Also, the WiFi configuration will be removed on the next software update. Official support for WiFi is coming in umbrelOS 1.1.


What Wifi Adapter are you using for this?
Is it a usb WiFi adapter?
does it matter the model?

Hi @expatsam no adapter needed!
If you’ve had any trouble with the steps above, please let me know and I can assist.

@expatsam to clarify, both Raspberry Pi 4 and Pi 5 already have WiFi modules on them, so you don’t need an adapter.

1 Like

@smolgrrr, thank you for this, it worked great!

1 Like

hi, i have the same problem, but i can’t figure out how to install the wifi drivers. After the UmbrelOS 1.04 flash procedure I put the sd into the raspi 4 and it stops on initializing XFRM netlink socket. I also don’t have a router with ethernet cable but use a hotspot from a smartphone. Can you explain me, I am going crazy :slight_smile:

Worked for me too - thx @smolgrrr

@smolgrrr, did WiFi make it into umbrelOS 1.1?

I see 1.1 just dropped :fire: , but no mention of WiFi.

If I upgrade will it kill my wifi config setup via nmcli?

Yeah, so sorry @nathanday and @carson-lee. umbrelOS 1.1.0 doesn’t include WiFi. 1.1.0 was supposed to be released in May, and we were planning to release 1.0.5 this week. However, due to the addition of new features (Terminal and the umbrelOS Beta Program), we had to tag it as a 1.1.0 release.

To confirm, WiFi will be included in the umbrelOS 1.2.0 release next month. If you’re currently using WiFi and update to the new release, your connection will be dropped after the update. So, make sure to use an Ethernet cable for the update process and reconfigure your device with WiFi after the update.

OK, understood. No need to apologise at all!

Just didn’t want to knock my node offline pre-halving with a rash upgrade!