How to solve Error: Failed to connect external drive

Up to a point there was no problem with umbrel,
But now, when I access umbrel, I get Error: Failed to connect external drive
Do you have any advice?

↓ Here’s what I did

At one point, I couldn’t access umbrel.
I turned off the power of the raspberry pie and started it.
The following screen came to appear.

Restarting doesn’t help.
After reading the umbrel-troubleshooting-guide, I ran ~ / umbrel / scripts / debug --upload and got the following log. This is part of the log.

==== Result ====
You have either no external drive connected to your Raspberry Pi or the drive is not being detected.
Please shutdown your Raspberry Pi ('sudo shutdown'), then plug the SSD into the other USB3 port.
After you've finished that, boot your Raspberry Pi back up. If it still still doesn't work,
you can contact us on Telegram ( and share the output of this script.

Shutting down and changing the USB port doesn’t help.
Do you have any advice?


  • the external drive is fucked, dead, corrupted - change it or re-format it / erase the partition and start over
  • the power source is bad, not original or had a bad voltage - change it
  • USB cable is bad, not compatible, or the USB port is failing - change it
  • external drive case is not compatible or is failing - change it.

thank you for your advice.
I will try to solve it with reference to them