Error: Failed to connect external drive


I need help!

I purchased all the required/recommended hardware and was successful in flashing the zip file over to SD micro (had to format it).

At the final step, when everything is connected, umbrel.local says, Error: Failed to connect external drive

“There was an error connecting your external drive. Please consider using the recommended hardware listed on”

Even though I can see that the light on the hard drive is solid. I even tried to re-format the hard drive but it didn’t help either. Please advise!

(Note: I used Windows 10 to download and format SD micro and external hard drive. Also, connected ethernet cable with raspberry pi.)



1 Like

It worked!

  1. rebuilt the sd micro flash by running “clean” (diskpart utility).

  2. ran “clean” on ssd (it kind of makes it factory default).

  3. also needed a new wire from usb 3 (A) to usb 3.1 © to connect raspberry pi (USB 3) to external hard drive (USB 3.1).

It is syncing now!

Thank you!


I have a very similar issue, when I first tried to setup my node I couldn’t get Umbrel (v0.3.14) to connect with the SSD.

My setup:

  • Raspberry Pi 4 Model B 8GB + Raspberry Pi 4 USB-C official power supply
  • Crucial MX500 1TB SSD
  • Orico HDD enclosure 2,5" SATA3.0 to USB3.1 Type C (model 2588C3)
  • Samsung Pro Endurance Micro SDHC 32GB - MB-MJ32G

I tried everything described above but couldn’t get Umbrel to connect with the SSD. I read on some other thread that it might work with an older version of Umbrel. I redid the setup with Umbrel v0.3.8 and suddenly Umbrel connected to the SSD perfectly and my node started syncing!

I updated Umbrel during the syncing to v0.3.14 without problems.

After fully syncing the blockchain and testing everything, I tried restarting the node.
Unfortunately after restarting I’m running again into the same issue and Umbrel can’t connect to the SSD (same error message).

Any options? I really would like to avoid syncing the complete blockchain again and have the same problem again later on…

Kind regards,

Good afternoon.
I have exactly the same problem already bought another 1TB SSD disk at the moment it doesn’t work anyway. The error is as shown above: “Error: Failed to connect external drive”

There was an error connecting your external drive. Please consider using the recommended hardware listed on

I don’t know what to do anymore.
Can anyone help?

1 Like

Hi ppl.
@Thor e @sanjay I solved my problem by buying the “Orico HDD Enclosure” box because it gives transfers up to 10GB. Apparently the problem was with the plug that was connecting the Raspberry to the box. It was all 5 stars and the box is beautiful because it is transparent.
Thank you all.

Thanks for the info @Tsunamy.

Unfortunately I can’t order from Amazon in my country and have to buy the recommended enclosure in some other way. I couldn’t find the transparent enclosure in an alternative shop, however I did find a black one with exactly the same specs (as far as I can see?):

As you can see, it can also transfer up to 10Gbps so this shouldn’t be the issue.

Was it the cable itself that was the issue?

Kind regards,

Good night @thor. Yes, this same record must give the difference must be in the “aesthetics”. It worked perfectly with me and there are two cables inside. USB - USB´C and USB´C - USB´C .

My disk

all this. Hope this helps.


Specs are identical to mine, so it would be unlikely that this is my issue.
Any devs out here that can help to troubleshoot?

I really don’t know how to continue…

I had same issue. It ended up being due to the fact that I wasn’t using a USB 3 cable to connect SSD to pi. Got a new USB 3.1 to USB C cable and now I could setup

I have the same issue. I’ve bought 100% of the recommended hardware off umbrel. Even ordered a replacement Crucial SSD incase the first SSD I received was corrupt, same issue.

It stays on “Starting Umbrel…” for a long time:

Then shows me the same “Error: Failed to connect external drive” error.

I’ve ssh’d into umbrel with ssh umbrel@umbrel.local then ran ~/umbrel/scripts/debug --upload and all I get is the following:

umbrel@umbrel:~ $ ~/umbrel/scripts/debug --upload
==== Result ====
This script could not automatically detect an issue with your Umbrel.
Please share the following links and paste it in the Umbrel Telegram group ( so we can help you with your problem.
tail: cannot open '/home/umbrel/umbrel/scripts/../logs/memory-monitor.log' for reading: No such file or directory
tail: cannot open 'logs/karen.log' for reading: No such file or directory

Note the This script could not automatically detect an issue with your Umbrel. line in the result of the script.

So, as it stands:

  • Using 100% of recommended hardware (Same ORICO connector one someone mentioned in this thread).
  • Using latest umbrel release.
  • Tried in both USB 3.0 and USB 2.0 ports on the RP4.
  • Tried multiple different recommended SSD’s.
  • No errors detected from script.

There’s nothing else I can think of. I’ve spent hours debugging this trying different ways and I’m pretty convinced it’s a bug with umbrel.

If anyone else has any ideas/solutions that worked for them please let me know.

Also forgot to mentioned ^ I’ve also re-flashed the SD card on every occasion after turning off/restarting umbrel or the RP4. Same error…

Update on my issue: It seems that the cable delivered with my Orico SSD enclosure was not a USB3 (type C to type A) cable even though the cover seems to state it is. You can actually check it quite easily by making sure the USB type C to A has a blue color inside the male type A socket. Just like the blue color on your Pi USB 3 sockets.

I bought a new cable and now the Umbrel seems to work fine…

I don’t have the recommended hard drive but I was running RaspiBlitz before so I know the hardware works.
So instead of spending $100 on another SSD I decided to see exactly what was happening at the OS level.
I ssh’d into the umbrel and ran lsusb and realized that the USB subsystem got disabled during boot, it wasn’t even recognizing my keyboard. Probably because of a power issue associated with mounting the SSD or something else, the entire USB ports shut down. So I disconnected the drive, rebooted and ran lsusb again, this time, the USB ports started working again (my keyboard showed up).
I then reconnected the SSD cd’d into the umbrel folder and manually ran the install script and viola! It worked!

I had the same issue. Tried with a case usb 2.0 connector and a usb 3.0 connector. Both failed even after partitioning, formatting ext4 and mountin the SSD

SOLUTION: Only the SATA-USB 3.0 case worked for me

1 Like

I recently got the parts for building my Umbrel node and have had the same issue with the SSD disconnecting. I shutdown the system when this happens, and it happens A LOT (see it happening with the % sync’d going down to zero and no more blocks being processed). I am using a Sandisk Extreme Pro 2 TB external drive. Since most of the reported problems with SSD disconnect seems to point to a power issue for the drive (and I am using an official Raspberry Pi power adapter), I have ordered a powered drive enclosure and a 2 TB Samsung SSD drive and will try using that (and use the Sandisk 2TB drive for something other than Umbrel), and hopefully that will fix the problem (have tried to use different Sandisk cables, different Raspberry Pi (4 Model B 8 GB) USB ports. It is hard for me to believe that powering an external SSD drive makes the Raspberry Pi/Umbrel software barf like it is doing. Hope that the new hardware (powered SSD drive enclosure) that should arrive shortly overcomes the problem. Only good thing about the problem was that it helped me learn more about the system, SSHing into the Umbrel server, running command line commands to see the system status, etc. But then again, would have liked to just get the node up and running, although not sure whatALL I will do with it once I get it up and running. Guess learn more about Lightning, and if I find that my Umbrel server is stable enough, guess I will connect a wallet to it and try to route transactions through it… I know - Umbrel is beta, not completely developed - so give it a break. But still…

Did some additional google internet research and found that the problem with Raspberry Pi’s loosing connectivity to external hard drives is a known problem (not just in the Umbrel world) and it is power related. So, what I think should happen is that Umbrel should let people who are in the process of purchasing hardware for an Umbrel node, know that power issues could come up with external drives connected to the USB ports, and that it is recommended to have a powered drive enclosure to overcome the problem (or use a powered hub - apparently some Raspberry Pi users have found this to work to overcome the problem with loosing external drive connectivity).

I had also issues while setting up Umbrel.
Unfortunately the support in this community here is almost 0…
I switched to Raspiblitz.
At first I had the same issue, but I figured that the Power supply on the USB Ports is too low.
I added a USB HUB with an external power supply and it worked.
Hope this will help someone…

I am here almost every day…
I repeat several times, even in this same thread, why this happen…
Also in many other posts.
I wrote several guides in this forum in the dedicated section Guides. In there is the troubleshooting manual and also the getting started guide, were is mentioned that most of the failures come from wrong hardware or configurations users are putting together.
Yourself you find out that was a hardware problem and not a software.

OK - followup… purchased a UGreen powered SATA3 enclosure and a Samsung SSD 2TB drive, and quickly installed it after it arrived yesterday… had one glitch where it appeared that after a few hours Umbrel bitcoin block syncing seemed to stall… I restarted the node and it came back up and was chugging away and has kept chugging away - currently at 37.8 percent sync’d… so, hopefully the sync will complete in a couple days, and I will be all sync’d up… haven’t downloaded any apps yet but want a block explorer so will probably try out mempool as a first app… so after all the headache/heartache of trying to use the Sandisk Extreme Pro 2TB external drive and the continual SSD disconnect error - am a happy Umbrel camper… hope I am not “speaking too soon” and the sync will complete… I worry that my basic, single fan, Raspberry Pi 4 case will get to overheat temps, but so far it is about 50 degrees C per Umbrel, and I guess that is OK to run at that temp…

Why people do not have patience?
Syncing the blockchain takes days, is a slow process and sometimes seems to be stuck but it isn’t.
Patience is the key…

1 Like

Followup to followup - after about 2 days after the new setup (external powered drive case), my Umbrel BitCoin and Lightning node was fully sync’d!! So that is REAL GOOD!! I turned it off for a few days when I was away on a short trip, as feared it might overheat. Came back, turned it on and it sync’d in several minutes, so that is mighty FINE… also, ordered a ICE Tower fan and case to keep my umbrel node nice and wayKEWL… things I still want to do - try to connect an external wallet to my Umbrel node, try to learn more about LightNing and try to open channels and do a transaction on it, etc… SUCH a really nice bitCoin learning tool!! VERY PLEASED after the initial problems/frustration with the node crashing, due to the external SSD drive that was apparently drawing too much power (but that too turned out to be a learning experience)…