How to reformat SSD on Mac


I had my Umbrel running fully synced, and then I had a power outage in my building.

How do I reformat the disk on a Mac with the correct settings? I tried opening up Disk Utility and reformatting with the default settings but when I plug in the SSD and visit umbrel.local, I get this error:

" Error: Failed to connect external drive"

Any tips on how to get the SSD to agree with the Raspberry Pi?



What hardware do you use? Also, what was the issue after the power outage that pushed you to reformat the SSD (and not just reaflash the microSD card)?

I’m using the 1TB SSD that’s recommended on the website with a Raspberry Pi 400.

The issue after the power outage was the loading screen was stuck in a loop

I had re-flashed the microSD and SSD with 0.3.12 and I would get the error " Failed to connect external drive"

I ended up using the firmware from 0.3.8 instead of 0.3.12 and the device booted up fine when I reformatted the SD card and SSD. I am going to stick with this to see if I can get a full node going again.

If you update to v0.3.12 and it still doesn’t work, please share with me privately the output of sudo dmesg. It is likely an hardware issue.

You can connect your SSD to your Mac, reinitialize, erase/reformat. Reconnect to your Umbrel/Pi…it will reformat to EXT4 as a new umbrel install. This means a new Umbrel setup. The Umbrel OS is on micro SD, but the umbrel account and block chain are on SSD.

I would also reflash the micro SD after power failure.

I do not know of a way to reformat without causing a new umbrel setup.