SSD not working with umbrel on startup


When I start up my raspberry pi 4 to start umbrel, it tells me that it has failed to connect with it.

All the hardware used for the node are the recommended ones.

I have tried reformatting it to ext4 with software from AOMEI. It has absolutely nothing on it other than the ext4 formatting. It is also brand new.

Please help :slight_smile:

Is the exact error you get when attempting to navigate to your dashboard Failed to attach to drive or Error system service failed? The latter would mean would need to reformat the drive again on the new installation the previous is we’d probably need to reconnect and reflash the MicroSD card

One thing to make sure is having a USB 3.0 cable, the cable itself should also have a blue finish on the connection and must be plugged into a USB 3.0 blue port, you can also unplug and try a different port after a reflash,

Let me know what else you’ve tried and happy to further assist

1 Like

The exact error I’m getting is: “Error: Failed to connect external drive There was an error connecting your external drive. Please consider using the recommended hardware listed on” This is happening when I try to connect to umbrel.local, I cannot get any further than that. Could you recommend a specific way of formatting it or should I use the software that I already used and just format it again the same way?

The cable is 100% the correct one :+1:

You can use AOMEI partition assistant and delete all the partitions on the drive and wipe the disk so it appears blank, it should say Select disk to wipe - and it will delete all partitions in AOMEI

Then we can power off, plug back everything after a reflash, plug in power last and try a different USB 3.0 port - if you have an external hard drive there may also be an activity light on the drive to indicate it’s detected - and the green light must also be flashing on the Pi 4, it may be redundant but may need to unplug and back in to make sure all these things become detected, show activity lights

Do I need to format the drive after deleting the partitions and wiping the drive?

By a reflash do you mean reflashing the OS on the SD?

Just want to make sure I understand everything that’s why I’m asking so much.

What kind of drive maybe your pi cant power it.

It’s the one recommended on The drive also lights up when I turn the pi on.

I followed the steps you gave and it still gives the same error. The drive has nothing on it and I plugged it in to a different USB 3.0 port. The lights come on, everything.

  1. open SSH connection and login
  2. Check internal/external SSD with the command
    lsblk -f

in the output you should see
sda1, patition, UUID of the SSD, size in gb and percent and very important mountponit
the mountpoint must be like this

if there is no mountpoint you have to either set/connect the mountpoint manually or start copying the umbrel image to the SD card again
so from the scratch

setting the mountpoint manually does not solve the problem.
You are just at the beginning

1 Like

When I run lsblk -f, the ssd does not show up. The ssd has been detected by the pi before and is not damaged in the slightest. I tried a second time after reflashing the OS and with a different USB 3.0 port and the same thing occured. My windows machine is able to detect it just fine.

All right Neon Tears,
one last attempt to help you.

1 you didn’t have a running umbrel on this Raspi with this hard drive, right?
2 you already tried to rewrite the SD card with the umbrel image and start the installation from the beginning, right?
3 you have already formatted the external USB hard drive once or several times with the tool “AOMEI”, right?
4 your external USB hard drive is one of the recommended ones on the umbrel page, right?

now answer the following questions:
4 name the manufacturer of the external USB hard drive or the built-in USB chip.
The name and model of the hard drive is also important. A photo is also very helpful.
3 why are you using a tool called “AOMEI” which is based on Linux when you are directly on a Linux distribution called “Debian” and can do patitions and formatting with it? Do you not know the fdisk command?
2 from which manufacturer is your SD card, name the exact model and do you have a second SD card on which you can copy the umbrel image?
1 send us a picture of your Raspi so we can see what you have the Raspberry Pi 4 in.

and last but not least …
if you entered lsblk -f you should see the following.

mmcblk0 is your entire SD card, mmcbblk0p1 is the boot area on the SD card and is formatted in vfat and mmcblk0p2 is the data area on the SD card and is formatted in ext4.
Now for the important part in your case

  • If sda is NOT present in the same query window, the system cannot initialise your external USB hard drive for TECHNICAL reasons!
    None of us can help you there. Only another external USB enclosure will help.
    In this case, I suspect that your Raspi cannot supply enough power to the external USB enclosure/hard drive. The reason for this is that a cheap USB chip was installed in the enclosure.
  • If sda is present and only sda1 is not present, a partition and a format must be made. Usually the umbrel installation does this automatically, but it can also be done manually try fdisk command.

Feedback please

1 Like

I have been able to run umbrel on this exact setup before not too long ago.

I am very new to linux and have little to no experience at all with it and do not want to break anything. I was recommended AOMEI as it was much easier to use for me personally.

The exact sd card i’m using is
I do not have a second one around.

The enclosure is one of the official raspi ones.

sda is not showing up at all. It’s interesting because it is showing up when I run bitcoin core on the pi but when I switch back to umbrel it’s gone.

Thank you for trying to help it means a lot :slight_smile:

Please explain how do you switch from umrel to bitcoin core?
Do you have 2 SD cards one with umbrel and one with bitcoin core?

1 Like

I just did it once to try it out and see if I should switch from umbrel to bitcoin core. All I did was wipe the drive to remove the umbrel stuff and flashed the sd card with raspi OS. Then I followed these steps:

i am confused …
if you want and you don’t care about the data on the SD card, we can test something.

##################### Preparation #####################

  1. download/install the “Raspberry Pi Imager” from the web page for your operating system (MS-Win or macOS)
    Raspberry Pi OS – Raspberry Pi

  2. open the “Raspi Imager” and choose under the operating system Rasberry Pi OS (OTHER) and then
    Raspberry Pi OS Lite (64-bit) Bullseye
    Published: 2023-05-03
    0.3 GB

  3. under the settings (cogwheel) i would enter the following
    → these are only examples and you please choose your own!

  • the hostname (umbrel-test.local)
  • use SSH (active) and password for authentication
  • username (umbrel) password (what you prefer)
  • for now no wfi
  • set language setting, timezone and keyboard layout
  • then flash the SD card with it

##################### Start #####################
4.0. start Raspi und open SSH connection

  • connect your 2TB hard drive
  • insert your SD card with the flashed PI OS Lite (Bullseye) into the Rasverry Pi slot and turn on
  • open the SSH connection to the Raspi, i use putty (MS-Windows)
  • now send the command
    lsblk -f

if now sda is displayed the error was on the umbrel image.
if sda is still not displayed it is on your ext. case.
And if I am completely honest I would only recommend something like this

It does not necessarily have to be this manufacturer, it is important that your 2TB are supported.

1 Like

I was using umbrel and it worked just fine a while ago. I wanted to switch from umbrel to bitcoin core (no third party things) to try it out. When I switched back to umbrel later, the drive stopped working with it.

try my test if you want, your hard drive is empty anyway if I understood you correctly.

1 Like

I would totally try it but I was able to download the arm linux installation of bitcoin onto the pi this morning and it’s performing the IBD right now. Thank you for spending so much time trying to help me tho you seriously should get paid for this type of stuff :slight_smile: